Plugins not available even if logged into MyVolumio account


I’m logged in into my MyVolumio free account and tried to access the plugin section of Volumio. Here I’m prompted with the message “To access the plugins store you need to login to MyVolumio”. I logged out from my account an logged in again but the error message comes up again. I also tried to restart my Raspberry Pi 3B+. Even with no success.
What could be wrong here?


This happened to me a while back when I first updated to v3. On one system it just started working the next day, on the other it needed a reflash of the SD card with a fresh volumio image.

2 questions: have you just updated to V3 from v2? If so, did you do the OTA upgrade (Systems/Update), or a fresh install?


I have this issue on two Volumio installations:

  • one is a fresh installation
  • the other one is a OTA upgrade of a decent Volumio V2

I had this same problem when configuring Volumio v3 with a fixed IP.
Reverting to “Automatic IP” solved the problem.
Reserving an IP on your router (DHCP server) is a workaround as it allow you assign a specific IP without having to set this in Volumio.

I tried it but have no luck so far. I still get the error message “To access the plugins store you need to login to MyVolumio”.

Does your device show that it is connected to MyVolumio? Is your device shown as connected on

My device Shows that I‘m logged in to my free account. But my devices are not shown in

Would you share some system logs please?

1 Like

Okay, here is the log file (DHCP enabled, logged in into MyVolumio):

Within the log file there’s a section about endpoints that can’t be reached. I logged in on my Raspberry Pi with Volumio and executed a ping for each of those failed endpoints. Every single endpoint was reached via ping.

I had this problem yesterday and fixed it.
The only change was that I’d been playing around with the fixed IP address settings for my Volumio systems. I already had this set up in the DHCP settings in my router, but added this via the nework settings in Volumio. Volumio became sluggish, multiroom stopped working and I got that message in the missing plugins section that I needed an account, even though it was logged in ok.
After I changed the setting back to Automatic IP in the network page and rebooted, everything was, and is still, working properly again.
I know many others have theirs set to fixed IP at router and Volumio level, but for me it always seems to cause problems.
In summary:

  • fixed IP set via the DHCP settings in my router + auto IP in my Volumio settings: perfect.
  • fixed IP in my router and in the Volumio settings: bricked.
  • auto IP in both works fine, but obviously can change address occasionally.

I double checked my configuration:

Volumio is set to DHCP and the router is not set to fixed IP for devices. This means that I use your recommended “auto IP in both” configuration. I restarted several times within the last days but still have no luck reaching the plugins.

Are you using some sort of IP filtering device such as Pihole?

Pinging endpoints is not the same as being able to interact with them.

Indeed, I’m using pihole. But there are now blocked domains in the query log visible.

Also I testet it witg pihole disbled and a restart of volumio with DHCP enabled. No luck. The log file for this could be found under

Are you running any firewalling software? It’s just odd that the endpoints are failing when run from Volumio, but are ok from the cli. Otherwise, I’m out of ideas sorry.

I think I found the solution:
For manual configuration of IP adresses there’s section for manually setting the DNS. If you switch to DHCP this manual setting is not deactivated.
After activating DHCP AND deactivating manual DNS settings I have access to the plugins.

This seems to be a bug in Volumio. Is this worth reporting?