[PLUGIN] YouTube2

Dear All, that was the problem. I’ve resized partition using other Linux machine and now everything working fine. Thanks a lot for your time & help.

I just switched to Volumio3 and can’t get YouTube2 plugin to work.
Device is ODROID-C2
Plugin version is 0.1.8

Failed to open “alsa”(alsa);
Error opening ALSA device “volumio”;
snd_pcm_hw_params() failed: Invalid argument.

From dmesg I see
[ 3.645343] ALSA device list:
[ 3.645349] #0: ODROID-HDMI

Is it somehow related?


nope this is a problem in volumio not in a plugin of volumio
i think all is not playing and not only the youtube plugin am i right?
it could be that you add on card is not set right.

Playing from local storage is working.
Radio Paradise plugin is working.
Only YouTube2 is not working.

YouTube2 plugin was working with same set-up on Volumio v.2
I’m using HDMI output for audio, no additional cards.

is there a hdmi out on volumio 3?
i see only my usb card or headphones i´m missing the hdmi out on it .


1 Like

that is a addon card on the odroid?

It is Odroid-C2 board, similar to rpi.
It’s own HDMI output, no additional boards, HiFi Shields or DAC’s.
And as I said it was ok on Volumio2 :slight_smile:

volumio 3 is a is a total different set-up i don’t know if odroid is supported in the plugin.
i’m more a rpi 4 guy but we shall ask patrick.

@patrickkfkan can you maybe anwser on this ?

This issue is not related to the plugin, as the plugin just sends the stream to MPD for playback.

On the other hand, could you try going to Playback Options in Volumio and turn on audio resampling, then choose 16-bit (target bit-depth) and 44.1kHz (target sample rate)?

1 Like

I set resampling as you suggested and this way it works. No errors.
What we can conclude from this?

It means the audio driver somehow determines that the Odroid hardware is incompatible with 48kHz audio streams (which YouTube provides). If you try playing any 48kHz audio, not just YouTube, you should get the same error if you don’t resample first.

Starnge. If I set resampling to 48kHz, it works. Also Youtube.

Maybe it’s the floating bit-depth that’s causing the error? What if you set Native bit-rate, but set target bit-depth to 16-bit

If I set sample rate to native Youtube still works.
But if I set Bit Depth to native it gives error.
In some reason it accepts manually all values. 16, 24 or 32 bits.

Then it could be that your Odroid cannot handle floating bit-depth (which is what MPD sees and shown as 32-bit in Volumio).

Is this part different in Volumio3 version?
Because in Volumio2 it worked without Audio Resampling.

Hi, Thank you for your plugin.
I want to ask that if this plugin support repeat/loop of the same video ?
I can play youtube music from my volumio but when i set to loop this music video, they simply run to the next on the playlist

Hi @Hung_The
I just tried playing a YT video, whilst clearing the Volumio queue. I then put the queue on repeat and it worked fine, without going to the next video.

I just tried with repeating a single song (repeat icon with a ‘1’), and @Hung_The is correct - it just moves to the next song in the queue.