[PLUGIN] Touch Display

This plugin is (mainly) working great for me - on a Pi 3A+ with RPi 7" screen.

One problem, though. I am using this screen to remote control another Volumio instance. When I shutdown the remote instance the twirling circle thing remains on the screen, so I cannot get to the local controls to shut down the screen’s Pi.

Is there a way around this without using a browser on a 3rd device to shut down volumio on all?

Thanks

Is it the same if you do it the other way around, i.e. shutting down the Pi from the other Volumio instance?

Also, do you have the same effect without using the touchscreen but a browser on a third device connected to the Pi to shut down the other Volumio instance?

If I shut the ‘screen’ Pi down first, I can n o longer turn the ‘playing pi’ down since the screen is now off! Again, I have to revert to a 3rd PC with browser.

If I do the same (i.e. navigate to the screen Pi website on a PC) and turn off the playing Pi from there, the same happens! i.e. the screen is taken up by the ‘wait’ twirl.

Can the UI recognise if it is working on a remote Volumio server, and return to the local one if that server is unavailable?

So the issue appears to be not specific to the touch display plugin as it occurs also when using the web interface on a third device.

In the meantime I have set up to Volumio systems (x86) as virtual machines. They show the same behaviour you described. That also argues for the issue not being related to the plugin.

To me it seems there could be a problem with multi room switching between devices. Might be related to the issues reported in the past, e.g.

https://community.volumio.org/t/multi-room-interface-switching/8269
https://community.volumio.org/t/multi-room-problems/8797/16

Maybe bring the issue to attention with a new thread describing the problem with turning off a Volumio system by using the multi room function.

What you could try for the time being is to connect a physical keyboard to your Pi and reload the interface by hitting F5.

Yes, it does seem that way. Not needed to do it before I started with the screen, so thought it was that. Sorry!

I just re-checked with exclusively the Volumio systems running in a VM (i.e. no Pi with touch display plugin in the network - just to rule out any side effect) and it made no difference: The problem you described appeared - hitting F5 on the system with the “blocked” UI makes it usable again.

Thanks. I tried the F5 too on a browser, and it returned to the right screen. However, the touch display does not have that.

If you connect a keyboard to the Pi F5 should work on the browser the touchscreen is showing, too.

It should, but I don’t want a keyboard connected.

I see.

Hello,

I try to bring an old POS 12" Touchscreen to work on a RPi3+ with the TouchDisplay Plug-in.
Display is showing everything OK, but I have just a RedHat driver and can’t install it via alien.
So the behavior of the touchscreen is like a mouse, means first tap gives the position, but it needs a second tap to click something. That is not working good, cause you have to hit the exactly same point to click.

Is there a posibility to change the mouse/tap behavior to point&click? So if you tap the screen the mouse knows to position and click at the same time.

What is the brand and model of your touchscreen and how is it connected? What is that RedHat driver? Can it be downloaded somewhere or could you PM me with the driver file?

It is a PointOfSale Monitor for checkout systems.
Wincor/Nixdorf BA82

You can find the drivers here:
https://www.dieboldnixdorf.com/en-us/support/documentation-services/pos-kiosk-systems-peripherals/driver-downloads/displays-graphics
first one in the list

They use an own Linux distro WNLPOS3/4 based on CentOS/RedHat and that is the driver made for.
The touch is connected via USB and is working like a standard-mouse device, the screen is connected via HDMI>DVI and works fine.

So, “DN Universal Touch Driver (UTD) for Linux (Version 2.2.3)” I guess? If so, which of the driver files from the .zip did you use specifically?

Right.
I tried to install the centos65-32, the others are 64bit.

If the installation of the driver succeeded you should have a file “options” in “/etc/opt/wn/wntouch”. Please post the outputs of

cat /etc/opt/wn/wntouch/options

and

ls -al /dev/input/wntouch*

Also check if the files
/opt/wn/wntouch/sbin/wntouch
/opt/wn/wntouch/bin/wnconfig
/opt/wn/wntouch/bin/wnmapping
/etc/opt/wn/wntouch/devices
/etc/X11/xorg.conf.d/99-wntouch.conf
and
/usr/share/hal/fdi/policy/20thirdparty/99-wntouch.fdi
are in place.

Sorry, what I don’t said, I want to install it on a Raspberry PI and the drivers made for i386.
So I cant install it on an ARM.

So my thoughts going to change the click-behavior in the touchdisplay plugin.
Or is there any kind of universal touchdriver?

According to the user manual the touchscreen indeed “registers” as a mouse:

"By default they are recognized as mouse by the kernel and
all events are routed to a /dev/input/mouseX device which is also auto-
matically used by the xorg server. "

That explains the clicking behavior you described. ATM I have no idea how to change that without wntouch binary which seems be available only for x86 devices.

Ok, thanks so far! I just try some hints and see what happens.

Stay healthy

PMed you.