[PLUGIN] NanoSound CD plugin

Hi , We have just released to support softvolume. Please follow the instructions as specified in [https://nanomesher.com/nanosound-cd-support/]

Volumio options -> i2s DACs which does not support hardware volume

1 Like

Thank you. I will give this a try, and let you know.

The issue with the software volume control is fixed after this latest update and following your instructions. Thank you.

There is however another issue. The album art is not displaying even though I have it enabled in the settings.

Can you try a CD which was not played before? I think the problem is that the meta was cached, so it didn’t refetch when you turn on the album cover option. We will improve this later. thanks

Yes it worked with another CD. Thanks.

I happily use the plugin. I would love that my kids could use the cd player without help. For that it would be very cool, if, after a cd has been put in the tray, it would auto start the playback. Do you think this would be possible to add?
Thanks a lot and kind regards

if someone is intrested. It is possible with the REST Api. My volumio instance is running on an raspberry pi.
you need 3 files:

curl localhost:3000/api/v1/v1/browse?uri=nanosound_cd | jq  '.navigation.lists[0].items' > myjson.txt
curl -i --header "Content-Type: application/json" localhost:3000/api/v1/commands/?cmd=clearQueue
curl -i --header "Content-Type: application/json" localhost:3000/api/v1/addToQueue --data "$(cat myjson.txt)"
curl -i --header "Content-Type: application/json" localhost:3000/api/v1/commands/?cmd=volume&volume=50
curl -i --header "Content-Type: application/json" localhost:3000/api/v1/commands/?cmd=play


curl -i --header “Content-Type: application/json” localhost:3000/api/v1/commands/?cmd=stop
curl -i --header “Content-Type: application/json” localhost:3000/api/v1/commands/?cmd=clearQueue


KERNEL=="sr[0-9]", ACTION=="change", ENV{ID_CDROM_MEDIA}=="1", ENV{ID_CDROM_MEDIA_STATE}!="blank", RUN+="/home/volumio/playcd.sh &"
KERNEL=="sr[0-9]", ACTION=="change", ENV{DISK_EJECT_REQUEST}=="1", RUN+="/home/volumio/stopcd.sh &"

chmod +x for the scripts and reboot. On my instance jq was preinstalled. If not sudo apt-get install jq

1 Like

Tried this plugin, can read and play CD but no sound (I am using USB DAC). After clicking “Auto reconfig audio” and restart, still no sound with CD and even cannot play files on my NAS with “Failed to open “alsa” [alsa];Failed to open ALSA device “hw:5,0”: Invalid argument” error. The output selection on Volumio setting disappeared. Has to reinstall Volumio to get playing NAS files works again. Googled and found exactly same problem ob Nanomesher forum (https://nanomesher.com/forum/topic/no-sound-with-nanosound-cd-using-a-topping-d10s-dac/) but no solution provided. Anyone can help on this?

Can you please share the content of /data/nanosound_cd/asound.conf ?

I have re-installed everything so I cannot share the asound.conf when the error happened. However, I have exactly the same error with the link I shared and it has the file shared. Can you check that one.

A potential solution is listed in (https://nanomesher.com/forum/topic/no-sound-with-nanosound-cd-using-a-topping-d10s-dac/

NanoSound CD didn’t work after I purchased it today. I emailed earlier with their support and they told me to install the earlier version as there are some “problems with the build libraries” - I guess this is due to the recent Volumio release (?).

Can anyone tell me how to install the earlier version please.

Just to give a bit more detail, below command failed in volumio 2.882 version.

apt-get install build-essential

returns below error:

The following packages have unmet dependencies:
build-essential : Depends: gcc (>= 4:4.9.1) but it is not going to be installed
Depends: g++ (>= 4:4.9.1) but it is not going to be installed
Depends: dpkg-dev (>= 1.17.11) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

A solution has been provided. Thank you 2aCD!


I have a Raspberry pi 3b+ connected to a smsl dac through USB port.Another USB port is connected to a 2tb usb hdd. I installed the CD plugin and connected an external USB LG DVD player (no separate power). The configuration was setup and the CD played well. But the problem is whenever I play a CD volumio loses the sight of the USB HDD. I have to restart once again and wait for the software to scan my entire music database (20 minutes approx) to play from my USB. Then if I again play my CD the USB drive vanishes.

Can anybody guide as to how to overcome this problem so that volumio can constantly see my USB HDD and DVD driver simultaneously.

This sounds like a power issue. What power supply are you using? Are both of your devices powered by USB only ? thanks

1 Like

May be. Actually I am using an official Raspberry Pi 3b+ power supply. Both HDD and DVD ROM are powered by RPi only through USB.

This indeed appears to be a power issue. Today I connected both the HDD and DVD ROM to the pi through a powered USB hub and both of them works well. Let me test for a few days more and I will be sure then. Thanks Nanomesher team.

1 Like

Hi there, Will this work with the Apple Superdrive?

Yes, it does. Thanks. There is a free version which you can try out.