[PLUGIN] NanoSound CD plugin

Can you please share the content of /data/nanosound_cd/asound.conf ?

I have re-installed everything so I cannot share the asound.conf when the error happened. However, I have exactly the same error with the link I shared and it has the file shared. Can you check that one.

A potential solution is listed in (https://nanomesher.com/forum/topic/no-sound-with-nanosound-cd-using-a-topping-d10s-dac/

NanoSound CD didn’t work after I purchased it today. I emailed earlier with their support and they told me to install the earlier version as there are some “problems with the build libraries” - I guess this is due to the recent Volumio release (?).

Can anyone tell me how to install the earlier version please.

Just to give a bit more detail, below command failed in volumio 2.882 version.

apt-get install build-essential

returns below error:

The following packages have unmet dependencies:
build-essential : Depends: gcc (>= 4:4.9.1) but it is not going to be installed
Depends: g++ (>= 4:4.9.1) but it is not going to be installed
Depends: dpkg-dev (>= 1.17.11) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

A solution has been provided. Thank you 2aCD!

https://community.volumio.org/t/cannot-install-build-essential-package/46856/13

I have a Raspberry pi 3b+ connected to a smsl dac through USB port.Another USB port is connected to a 2tb usb hdd. I installed the CD plugin and connected an external USB LG DVD player (no separate power). The configuration was setup and the CD played well. But the problem is whenever I play a CD volumio loses the sight of the USB HDD. I have to restart once again and wait for the software to scan my entire music database (20 minutes approx) to play from my USB. Then if I again play my CD the USB drive vanishes.

Can anybody guide as to how to overcome this problem so that volumio can constantly see my USB HDD and DVD driver simultaneously.
Regards

This sounds like a power issue. What power supply are you using? Are both of your devices powered by USB only ? thanks

1 Like

May be. Actually I am using an official Raspberry Pi 3b+ power supply. Both HDD and DVD ROM are powered by RPi only through USB.

This indeed appears to be a power issue. Today I connected both the HDD and DVD ROM to the pi through a powered USB hub and both of them works well. Let me test for a few days more and I will be sure then. Thanks Nanomesher team.
Regards

1 Like

Hi there, Will this work with the Apple Superdrive?

Yes, it does. Thanks. There is a free version which you can try out.

hello nanomescher,
I have a slot-in drive with no physical eject button.
Every time I want to eject the CD, I have to press View Settings–>Plugins–>Installed Plugins–>Settings of Nanosound CD–>Eject Button.

It would be very nice if you could add a separate eject button directly in the browse menu under NanoSound CD. With an additional eject button, I would listen to audio CDs more often than I do now.

thank you nanomesher for the great cd plugin.

1 Like

I concur, it’s a great plugin but I also use a slot-in drive, so an easily accessible eject button would be very welcome!

Hello Nanomesher Team,

I need help :frowning: I got a SATA drive and installed the Nanosound CD plug in, however It doesn’t seem to be working,

it does allow me to eject a CD through Volumio, however it does not ready the contents of the CD at all :frowning: I did test the drive on my Windows 10 machine and it seems to be working 100%

I am currently using a Raspberry Pi 4 - 8GB with a 128GB memory card.

Thanks in advance :slight_smile:

Hi,

I am using a IQaudio Dac Plus with Volumio 2.882 and the plugin installed. It has been working previously very well but since I
changed the mixer type to none the cd plays but no sound comes out. I tried auto config audio and
it still didnt work. I then changed the mixer back to software and did the auto config again
and it still did not work.

the results from /data/nanosound_cd/asound.conf can be found below

defaults.pcm.card 2
defaults.ctl.card 2

ABOVE LINES WERE ADDED BY NANOSOUND CD

BELOW LINES WERE ADDED BY NANOSOUND CD

defaults.pcm.rate_converter “speexrate_best”

pcm_slave.x4 {
pcm “hw:2,0”
rate 176400
}

pcm_slave.x2 {
pcm “hw:2,0”
rate 88200
}

pcm.rate_convertx4 {
type rate
slave x4

Any help would be appreciated as it was a great plugin.

Can you please paste the content of /etc/asound.conf ?

thx

Its empty.

Capture

Change you please change it to </data/nanosound_cd/asound.conf>

or just run

echo “</data/nanosound_cd/asound.conf>” | sudo tee -a /etc/asound.conf

thanks

1 Like

It could be a power issue. Do you hear it spins? thanks