[PLUGIN] NanoSound CD plugin

We have found the issue recent issue where NanoSound CD cannot load the song list when clicking on “NanoSound CD” icon.
The issue is due to the FREEDB (one of the album database we use) has been shutdown.

We have released a fix for armv7 cpu include Raspberry Pi. Please reinstall NanoSound CD or use the Upgrade Version button from the NanoSound CD plugin screen.

x86 version will be coming.

Thanks

Hi!
Has the fix for x86 been released? I have this exact problem. If it has not been released yet, can I tweak something manually to temporary fix it?

Hi, x86 version has been released with this fix.

Just reinstall Nanosound CD plugin. Thanks for the wait!

Even more good news! We have are now using a new CDDB which have improved the recent problems with fetching the CD meta. Please upgrade to 2020-08-09 version. It is available to both x86 and Pi platform.

Thank you gnudb team!

thanks!

The new version to extract artist and album names is now available in v1.2 for both x86 and arm versions.

More details are here

Hope you enjoy it!

@nanomesher,
Please help with my issue here:

Hi, have you tried using Mixer Control Name: PCM ?
Which DAC do you use?

The only two mixer options I have in volumio are software or none

Here are some of the config files from your website that you mention:

asound.conf


volumio@volumio:~$ cat /etc/asound.conf

pcm.softvolume {

type plug

slave.pcm "softvol"

}

 

pcm.softvol {

type softvol

slave {

pcm "plughw:2,0"

}

control {

name "SoftMaster"

card 2

device 0

}

max_dB 0.0

min_dB -50.0

resolution 100

}

/data/nanosound_cd/asound.conf


volumio@volumio:~$ cat /data/nanosound_cd/asound.conf

defaults.pcm.card 2

defaults.ctl.card 2

 

defaults.pcm.rate_converter "speexrate_best"

 

pcm_slave.x4 {

pcm "hw:2,0"

rate 176400

}

 

pcm_slave.x2 {

pcm "hw:2,0"

rate 88200

}

 

pcm.rate_convertx4 {

type rate

slave x4

converter "speexrate_best"

}

 

pcm.rate_convertx2 {

type rate

slave x2

converter "speexrate_best"

}

aplay -l


**** List of PLAYBACK Hardware Devices ****

card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]

Subdevices: 4/4

Subdevice #0: subdevice #0

Subdevice #1: subdevice #1

Subdevice #2: subdevice #2

Subdevice #3: subdevice #3

card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 IEC958/HDMI [bcm2835 IEC958/HDMI]

Subdevices: 1/1

Subdevice #0: subdevice #0

card 0: ALSA [bcm2835 ALSA], device 2: bcm2835 IEC958/HDMI1 [bcm2835 IEC958/HDMI1]

Subdevices: 1/1

Subdevice #0: subdevice #0

card 1: Headphones [bcm2835 Headphones], device 0: bcm2835 Headphones [bcm2835 Headpho nes]

Subdevices: 3/3

Subdevice #0: subdevice #0

Subdevice #1: subdevice #1

Subdevice #2: subdevice #2

card 2: sndrpirpidac [snd_rpi_rpi_dac], device 0: RPi-DAC HiFi pcm1794a-codec-0 [RPi-D AC HiFi pcm1794a-codec-0]

Subdevices: 0/1

Subdevice #0: subdevice #0

cat /proc/asound/modules


0 snd_bcm2835

1 snd_bcm2835

2 snd_soc_rpi_simple_soundcard

cat /proc/asound/cards


0 [ALSA ]: bcm2835_alsa - bcm2835 ALSA

bcm2835 ALSA

1 [Headphones ]: bcm2835_headphonbcm2835 Headphones - bcm2835 Headphones

bcm2835 Headphones

2 [sndrpirpidac ]: RPi-simple - snd_rpi_rpi_dac

snd_rpi_rpi_dac

Hi , We have just released to support softvolume. Please follow the instructions as specified in [https://nanomesher.com/nanosound-cd-support/]

Volumio options -> i2s DACs which does not support hardware volume

1 Like

Thank you. I will give this a try, and let you know.

@nanomesher
The issue with the software volume control is fixed after this latest update and following your instructions. Thank you.

There is however another issue. The album art is not displaying even though I have it enabled in the settings.

Can you try a CD which was not played before? I think the problem is that the meta was cached, so it didn’t refetch when you turn on the album cover option. We will improve this later. thanks

Yes it worked with another CD. Thanks.

I happily use the plugin. I would love that my kids could use the cd player without help. For that it would be very cool, if, after a cd has been put in the tray, it would auto start the playback. Do you think this would be possible to add?
Thanks a lot and kind regards

if someone is intrested. It is possible with the REST Api. My volumio instance is running on an raspberry pi.
you need 3 files:
/home/volumio/playcd.sh

#!/bin/bash
curl localhost:3000/api/v1/v1/browse?uri=nanosound_cd | jq  '.navigation.lists[0].items' > myjson.txt
curl -i --header "Content-Type: application/json" localhost:3000/api/v1/commands/?cmd=clearQueue
curl -i --header "Content-Type: application/json" localhost:3000/api/v1/addToQueue --data "$(cat myjson.txt)"
curl -i --header "Content-Type: application/json" localhost:3000/api/v1/commands/?cmd=volume&volume=50
curl -i --header "Content-Type: application/json" localhost:3000/api/v1/commands/?cmd=play

/home/volumio/stopcd.sh:

#!/bin/bash
curl -i --header “Content-Type: application/json” localhost:3000/api/v1/commands/?cmd=stop
curl -i --header “Content-Type: application/json” localhost:3000/api/v1/commands/?cmd=clearQueue

/etc/udev/rules.d/99-local.rules

KERNEL=="sr[0-9]", ACTION=="change", ENV{ID_CDROM_MEDIA}=="1", ENV{ID_CDROM_MEDIA_STATE}!="blank", RUN+="/home/volumio/playcd.sh &"
KERNEL=="sr[0-9]", ACTION=="change", ENV{DISK_EJECT_REQUEST}=="1", RUN+="/home/volumio/stopcd.sh &"

chmod +x for the scripts and reboot. On my instance jq was preinstalled. If not sudo apt-get install jq

1 Like

Tried this plugin, can read and play CD but no sound (I am using USB DAC). After clicking “Auto reconfig audio” and restart, still no sound with CD and even cannot play files on my NAS with “Failed to open “alsa” [alsa];Failed to open ALSA device “hw:5,0”: Invalid argument” error. The output selection on Volumio setting disappeared. Has to reinstall Volumio to get playing NAS files works again. Googled and found exactly same problem ob Nanomesher forum (https://nanomesher.com/forum/topic/no-sound-with-nanosound-cd-using-a-topping-d10s-dac/) but no solution provided. Anyone can help on this?

Can you please share the content of /data/nanosound_cd/asound.conf ?

I have re-installed everything so I cannot share the asound.conf when the error happened. However, I have exactly the same error with the link I shared and it has the file shared. Can you check that one.

A potential solution is listed in (https://nanomesher.com/forum/topic/no-sound-with-nanosound-cd-using-a-topping-d10s-dac/