[PLUGIN] MPD OLED - installation & configuration plugin

what line was that? I’m not sure the volumio plugin works if mpd_oled is running as service, I might be wrong as I can’t remember :face_with_hand_over_mouth: :face_with_hand_over_mouth: You might need to copy mpd_oled to the bin folder from it’s binary location using cp mpd_oled /usr/local/bin/mpd_oled

i followed the installation method using binary and ive been typing mpd_oled -o for 3hrs instead of using
sudo mpd_oled -o

what am i doing with my life

TLDR
im using these for 3hrs

mpd_oled -o 6 -b 10 -g 1 -f 20

instead of this

sudo mpd_oled_service_edit -o 6 -b 10 -g 1 -f 20

And thanks for your replies sir!

here’s my setup tho

OrangePi One / Zishan Z1 DAC/DAP With ES9023 Dac Chip and AD8066 Custom OpAmp

i also integrated zishan z1 buttons and potentiometer in OrangePi GPIOs

3D Printing a case to make it portable

You shouldn’t need to type anything into the console? Did you install the plugin so you can control mpd_oled from Volumio? That’s the point of my plugin :rofl: :rofl: :rofl:

Nice setup! If you don’t want to configure your screen using the plugin then you can just stick to installing mpd_oled as a service. :slight_smile:

yes sir i was so confused about this and here i am now smiling like a child coz its working now haha

HI!
How do I need to set the system time on Volumo?
On OLED, the time is 2 hours away from my time.
Thanks

sudo dpkg-reconfigure tzdata

Hi supercrab,
I don’t know whether it is appropriate to ask my question here, because I think it is more hardware related, but it also seems that a software tweak in your oled plugin might solve the problem, so I still want to present my problem here and hope that somebody can help me with it! Thanks!

I have installed this OLED plugin with the latest 2.909 and using a SH1106 compatible 1.3" OLED display and it works OK. But my setup is a bit different because I am using the Allo Boss2 dac which also has an OLED display with default address 3C. So I changed the address of this 1.3" display to 3D.
Now when I boot up Volumio, only the Boss2 OLED will light up and to get my second MPD OLED to light up, I have to go into the OLED plugin and either switch it on and off once or go one step further to the settings of the plugin and press the save button once more. Then the second OLED will light up and works properly.

I know that this is a reset issue, but there are only 4 pins on my OLED and no reset pin. I’ve tried adding pull up resistors of 4.7K to both the SCL and SDA pins without avail. I’ve tried adding a 100uf small capacitor to the VCC and GND to stabilize the 5V supply a bit and still no luck. Can somebody help me on this? Thank you.

I’m not sure what’s that issue sorry :worried: You could try running mpd_oled on the command line and see if that works any different?