[PLUGIN] MPD OLED - installation & configuration plugin

Hi

After succes instalation and updte I was like to update the Volumio, but get next message:

“Update failed
System Software Integrity check failed, manually edited files were detected. System Software Update is not possible under these circumstances. Please execute a Factory Reset or Delete User Data, then retry.”

Try uninstall the plugin, update and then re-install?

The plugin has been submitted to Volumio dev.

Thanks everyone :smiley:

Mase (supercrab)

1 Like

Just a massive thank you to you guys - your skill is intimidating and you can feel considerable pride in your work and generosity!
I’m running mpd_oled on 2 devices and I love it
Here’s one of my players > https://twitter.com/sickly_b/status/1327542884783042561?s=21

1 Like

Great job! Well done!

When the buster beta will be released (together with the new ALSA pipeline), it should be possible to create the pipeline directly from alsa (like @balbuze did for his peppymeter plugin), without changing the mpd configuration. This will result with all sources working properly (mpd, spotify, spotify connect, etc.) and no edit to files in /volumio/ folder (that will prevent OTA update)

Nice work on your builds and I appreciate you kind words :slight_smile: It makes me happy that people are using it and I feel relieved and shocked that it works so well!

Still, most of the hard work was done by the mpd_oled author. The plugin is just the icing on the cake really :smiley:

Thanks, I’m happy to have it all wrapped up now :slight_smile:

I’ll be interested to see what new release is like and what can be done with the new audio configuration, although, I think most of it will be over my head!

Hi,

Can’t install the plugin at Rpi 3 b v1.2, last Volumio 2.861 fresh install.

In /tmp/oled directory, volumio plugin install hangs at
Downloading plugin :

root@volumio-pi-300:/tmp/oled/mop# volumio plugin install

This command will install the plugin on your device

Compressing the plugin
Plugin succesfully compressed
Progress: 10
Status :Downloading plugin
Downloading plugin at http://127.0.0.1:3000/plugin-serve/mpd_oled.zip

If I run install.sh in ./mod (chmoded it before), lots of things happened without errors in console log, but the plugin does not appear in UI. There’s also no files in /data/plugins/ and no volumio-plugins directory an /home/volumio/.

Do not use root as user but Volumio

Hi!
After the
volumio plugin install
command, the installation is stuck here for me.
?

Volumio VERSION: 2.861
RELEASE DATE: 22-12-2020
Raspberry PI 3B+
Thanks!

Should be ok. Ctrl+c and go into the UI to enable it.

1 Like

Thanks!

Thanks @balbuze for helping.

@Don_Frenk did you go this page for the instructions?

The page explains the need to do hit Ctrl + C when installation finishes. :flushed::thinking::grimacing:

Thanks!
Sorry!

1 Like

No worries :grinning: Hope your screen is working now. :+1:t4:

What’s wrong with root ? If without sudo, it stops even earlier :

volumio@volumio-pi-300:~/mop$ volumio plugin install

This command will install the plugin on your device

Compressing the plugin
Plugin succesfully compressed
/bin/mv: inter-device move failed: ‘mpd_oled.zip’ to ‘/tmp/plugins/mpd_oled.zip’; unable to remove target: Permission denied
child_process.js:644
throw err;
^

Error: Command failed: /bin/mv *.zip /tmp/plugins/mpd_oled.zip
/bin/mv: inter-device move failed: ‘mpd_oled.zip’ to ‘/tmp/plugins/mpd_oled.zip’; unable to remove target: Permission denied

at checkExecSyncError (child_process.js:601:13)
at execSync (child_process.js:641:13)
at install (/volumio/pluginhelper.js:689:9)
at Object.<anonymous> (/volumio/pluginhelper.js:751:9)
at Module._compile (module.js:652:30)
at Object.Module._extensions..js (module.js:663:10)
at Module.load (module.js:565:32)
at tryModuleLoad (module.js:505:12)
at Function.Module._load (module.js:497:3)
at Function.Module.runMain (module.js:693:10)

I’m not sure what’s happening there. I’ve always ran volumio plugin install under the volumio user. :weary:. What version of volumio are you running? Does the plug-in install with your way?

I finally done it. The files created by root caused these errors. I deleted them manually, and the plugin has been installed. But the display (o2c) is still black. Will try another one, SPI, which needs some soldering.

1 Like

Thanks for everything!
Everything works fine!
And special thanks for the Rotary Encoder plugin!

1 Like

Very nice setup! I haven’t tried the rotary plug-in yet! :disappointed: