[PLUGIN] miniDLNA

Quick question: I noticed that the scanned library on my mounted drive includes none of my DSD files, which is a shame because I have some of my favorite albums in that format.

Any plans to enable streaming of those files? I know there is nothing in the DLNA protocol itself that prevents that.

Volumio 2 is Debain Jessie based where only miniDLNA 1.1.2 is available. It does not support DSD.

Volumio3 will be based on Debian Buster and will get miniDLNA 1.2.1 as soon as my PR on GitHub has been reviewed and the plugin been merged to the Volumio3 plugin store. Unfortunately miniDLNA 1.2.1 does not support DSD, too. :frowning:

miniDLNA has DSD support only as of version 1.3.0. miniDLNA 1.3.0 will be available on Debian Bulleyes based systems… so depending on if and when Volumio switches to Debian Bullseye, it might take a while until miniDLNA with DSD support becomes available.

Thank you for this information. Sounds like DSD support isn’t coming anytime soon. :frowning:

Now I am feeling a bit dumb.

I bought a Raspberry Pi 4 and moved Volumio from my NUC to the RPi.

I had no problem either mounting my NAS for the main library or installing the DLNA plug-in. However, when I try to mount the same NAS as the DLNA server database mount, I get the error message that the audio files directory does not exist.

The IP address for the NAS is 192.168.0.10. The network share for the music files is \medianas\music. The main library mount is \192.168.0.10\music.

I have tried both \medianas\music and 192.168.0.10\music, as well as just \medianas and \192.168.0.10, and I get the same error message every time.

Volumio shows up as a DLNA server in the control software, but the library is 0 files. When I first installed the miniDLNA plugin on the NUC, I had no problem mounting the drive as the DLNA library and populating it.

Have you any thoughts about what I might be doing incorrectly? Thank you for your help.

Then I would expect the path to the mounted network share to be /mnt/NAS/music. This path would have to entered on the plugin’s config page as “Audio Files Directory”.

Thanks, but that didn’t work, either, unfortunately. (I am certain that I didn’t configure the settings that way when I had the NAS mounted previously.)

I did a search and found references to changing permissions on Synology NAS’S, but, unfortunately, not including an explanation of what needs to be changed. I guess I should look more closely at the permissions issue.

Please connect to Volumo via SSH and post the result of

ls -al /mnt/NAS

volumio@volumio:~$ ls -al /mnt/NAS
total 16
drwxrwxrwx 1 root root 4096 Dec 2 02:43 .
drwxrwxrwx 1 root root 4096 Oct 6 10:34 …
drwxrwxrwx 2 root root 0 Dec 2 03:37 MediaNAS
volumio@volumio:~$

Thank you for your help. I hope this is useful.

Aha, not “music” is mounted but “MediaNAS”. So, set “Audio Files Directory” to

/mnt/NAS/MediaNAS

or if “music” should be a subfolder of “MediaNAS” to

/mnt/NAS/MediaNAS/music

Same result, unfortunately.

volumio@volumio:~$ ls -al /mnt/NAS
total 16
drwxrwxrwx 1 root root 4096 Dec 2 02:43 .
drwxrwxrwx 1 root root 4096 Oct 6 10:34 …
drwxrwxrwx 2 root root 0 Dec 2 03:37 MediaNAS
volumio@volumio:~$

Did you also try /mnt/NAS/MediaNAS as “Audio Files Directory”?

And what’s the ouput of

ls -al /mnt/NAS/MediaNAS

?

Yes, I did try that as an alternative.

I think the problem may have be solved, though. I enabled NFS, which is nit enabled on Synology as a default. I then entered various combinations of IP address, MediaNAS, and MediaNas/music, with and without NAS in the string.

Now, when I bring up Volumio DLNA in a controller app, I find three (!) identical MediaNas directories from which to choose. :slight_smile:

How do I get rid of a couple of them? :slight_smile:

I assume it also failed. Btw could post the output of

ls -al /mnt/NAS/MediaNAS

Apart from that: What are the current settings for the media dirs on the plugin’s config page?

Could you post a picture showing this situation?

Do you run multiple instances of the miniDLNA plugin and/or other DLNA servers which possibly use the same media directory?

No, no other miniDLNA instances. I was using Mconnect on the iPad. Volumio DLNA is only one of several DLNA servers running at the same time and they all use the same data directory, but Volumio only appears as a single instance on the DLNA server list.

Thanks for helping out. I appreciate it.

I spoke too quickly about the issue of the three separate but identical shares appearing in Mconnect.

Each of those three servers is populated with these fields;

This appears to be normal. What you are seeing are the three directories set for audio files ("/mnt"), picture files ("/mnt") and video files ("/mnt"). Consequently, if you open each one you will see the subfolders “INTERNAL”, “NAS”, “UPNP” and “USB” everytime which are located in “/mnt”.

To avoid seeing the directories specified for all media types you should be able to select either “Music”, “Pictures” or “Video” instead of “Browse Folders” in Mconnect.

Regarding setting /mnt/NAS/MediaNAS/music as “Audio Files Directory” :

The reason why setting /mnt/NAS/MediaNAS/music as “Audio Files Directory” fails is simply that “music” does not exist below /mnt/NAS/MediaNAS/, :wink: but there are various “FLAC …” named folders. Could you just for testing purposes try to set one of those folder (e.g. /mnt/NAS/MediaNAS/FLAC Blues) as “Audio Files Directory” in the plugin?

Hmmm. You are correct that that works, but it looks as though it will be a pain to deal with here. There indeed is a directory of Media NAS called “Music,” and each of the FLAC folders is within that. Unfortunately, there is a total of 17 music folders within “Music,” eight FLAC, eight hi-res, and mp3. (They hadn’t all populated by last night because I am setting up new, larger drives that arrived two days ago and my content still is copying over. I guess I will need to make a directory string that includes all 17 subfolders. I wi try that this evening and let you know if that works.

Thanks. Without your guidance, I never would have figured out to add the NAS folder and use the subfolders and not the Music folder.

According to the result of ls -al /mnt/NAS/MediaNAS you posted above: No, there is no folder called “Music” above the “FLAC…” folders. At least a “Music” folder which may be on the NAS is not accessible for Volumio. Possibly this has to do with how / to which directory level of the NAS the network drive is connected.

Please head to “Sources” and post a picture of the details of the network drive which are shown if you click on the edit icon for the drive.

This would be suboptimal IMHO. It should be possible to mount the folder that contains the “FLAC…” folders and to use this single folder as minuDLNA’s “Audio Files Directory”.

Here are the edit details. I believe that I mapped to 192.168.0.10 rather than medianas because medianas wouldn’t take.

So the folder Music on the NAS is mounted to /mnt/NAS/MediaNAS on Volumio. I suggest to change the Alias MediaNAS to Music and check if /mnt/NAS/MediaNAS is renamed to /mnt/NAS/Music afterwards. Then try setting “Audio Files Directory” on the plugin’s config page to /mnt/NAS/Music.