[PLUGIN] miniDLNA

i went to 2x version 3.074 now you could even skin volumio,
sorry for the late response i was watching soccer.
and ended in crying on the couch.

tnx @gvolt for filling up the gab …i just went with filling up my beer.

what do you mean skin volumio? you werent able before?
i ended up updating also one of my rasberries on v3.074 because for some reason only this device is freezing on v2…its crazy i give up.
at least i added everything except spotify i guess when they release the final version is going to be also available.
and miniDLNA works fine.

with the newer 3.074 you can add a skin like option… eazy install instead of the peppy version

thats nice yeah.

i’m creating skins for it and in the next update yt will be fixed too.
so all will look nice.

@gvolt
First of all I’d like to thank you for your work on that plugin.

Said that, let me introduce some problems I put myself in regard to using miniDLNA.
I described my story here: Frustrations with SLOW interface on Raspberry Pi 4B - 15s++ loading times - #5 by uniqueusername

TLDR:
miniDLNA messes with Volumio in a way that makes Volumio’s UI crazy unresponsive. I’ve been dealing with that issue for a couple of months, unable to point to the plugin, as it isn’t squeezing any substantial resources out of the computer I run my Volumio on. There’s also nothing interesting in the logs.
At the end, after disabling miniDLNA Volumio is operating normally and snappy. I made a couple of tests switching the plugin on and off, and I’m sure that it’s its fault. On the other hand I can’t figure out what is going on there, and I’d like to figure this out. I need DLNA server.
PS: First thing that comes to mind is that miniDLNA might be indexing a music database, but I assure you that’s not the case. The problem is persistent regardless of what miniDLNA is doing; when it’s active - Volumio is slow as hell.

I’d like to kindly ask you to inspect my problem, letting us know if it’s an isolated case or maybe we have a bigger problem here.
I’d be happy to provide any data from my system helpful to solve the issue.

Cheers!

I can’t replicate your issue.

Neither on a Pi3 nor on a Pi4 (2GB) based Volumio (2.907) system with a USB HDD holding round about 150 GB of FLAC files and folder.jpg files switching the miniDLNA plugin on or off had an impact on how fast the UI loads. This applies for connecting by LAN (1GBit, WLAN disabled) as well as for using WLAN.

OK, thanks for letting me know.

Let me do one more thing before we’re going to proceed any further. The only thing that differentiates your params from mine is that my FLACs don’t have *.jpg covers - my whole library has embedded graphics. I was planning to change that (strip down the files and export covers into JPGs), since my current model doesn’t work well with Volumio.

Regardless of whether it’s the embedded covers or not that impact miniDLNA, I’ll let you know here soon.
Thank you for being responsive.

Thanks a lot for the plugin!
I would like to now, is there any chance that the plugin can also get Digital Media Controller (DMC) features:
A DMC finds content on digital media servers (DMS) and instruct digital media renderers (DMR, in my case a Pro-Ject Stream Box DS net or Pro-Ject Stream Box S2) to play the content.
This are DLNA Certified Device Classes.

Thank You and KR
Arno

Hi @ArnoG,

the plugin just installs a MiniDLNA (ReadyMedia) server and provides access to the server’s options through the config page. So the plugin is limited to the functionality of MiniDLNA which is not a DMC, but a DMS only. I.e. it is not capable of instructing renderers what content to play.

Hi, thanks for the fast replay, that means the mini DLNA is today not able to work as a DMC…
Anny ideas for a DLNA Server incl DMC functionality ?
Thank You an KR from Vienna

Arno

Exactly.

No, unfortunately not.

Thank You for your fast answers and support !
KR

Arno

My pleasure! :slight_smile:

Thank you, gvolt! I have Volumio beta working as a DLNA server now, which I previously thought impossible. Glad that someone referred me to this post.

1 Like

Quick question: I noticed that the scanned library on my mounted drive includes none of my DSD files, which is a shame because I have some of my favorite albums in that format.

Any plans to enable streaming of those files? I know there is nothing in the DLNA protocol itself that prevents that.

Volumio 2 is Debain Jessie based where only miniDLNA 1.1.2 is available. It does not support DSD.

Volumio3 will be based on Debian Buster and will get miniDLNA 1.2.1 as soon as my PR on GitHub has been reviewed and the plugin been merged to the Volumio3 plugin store. Unfortunately miniDLNA 1.2.1 does not support DSD, too. :frowning:

miniDLNA has DSD support only as of version 1.3.0. miniDLNA 1.3.0 will be available on Debian Bulleyes based systems… so depending on if and when Volumio switches to Debian Bullseye, it might take a while until miniDLNA with DSD support becomes available.

Thank you for this information. Sounds like DSD support isn’t coming anytime soon. :frowning:

Now I am feeling a bit dumb.

I bought a Raspberry Pi 4 and moved Volumio from my NUC to the RPi.

I had no problem either mounting my NAS for the main library or installing the DLNA plug-in. However, when I try to mount the same NAS as the DLNA server database mount, I get the error message that the audio files directory does not exist.

The IP address for the NAS is 192.168.0.10. The network share for the music files is \medianas\music. The main library mount is \192.168.0.10\music.

I have tried both \medianas\music and 192.168.0.10\music, as well as just \medianas and \192.168.0.10, and I get the same error message every time.

Volumio shows up as a DLNA server in the control software, but the library is 0 files. When I first installed the miniDLNA plugin on the NUC, I had no problem mounting the drive as the DLNA library and populating it.

Have you any thoughts about what I might be doing incorrectly? Thank you for your help.

Then I would expect the path to the mounted network share to be /mnt/NAS/music. This path would have to entered on the plugin’s config page as “Audio Files Directory”.