[PLUGIN] Logitech Media Server - Docker Edition

Hi everyone,

I’ve made a plugin that installs a Dockerized version of Logitech Media Server on Volumio.

NOTE: devices with ARMv6 processors such as Raspberry Pi 0 are not supported. Do not install this plugin on such devices.

Source / readme: https://github.com/patrickkfkan/volumio-lmsde

The LMS version installed by this plugin is v8.2.1.

Plugin has been submitted to the plugin store and pending acceptance. In the meantime, you can test it by manual installation:

// ssh into Volumio, then copy and paste each line after the $ sign into your ssh terminal

$ git clone https://github.com/patrickkfkan/volumio-lmsde.git
$ cd volumio-lmsde
$ volumio plugin install

Depending on your hardware and network speed, installation can take some time.

Related plugin: Squeezelite MC - installs and runs an LMS client player on Volumio.

Have fun!

-Patrick

2 Likes

It’s working very well, thanks for this

1 Like

Hi! I tried to install LMS-docker. Installation went fine but I couldn´t activate the plugin. I guess I have to try it with a fresh Volumio install since I earlier had LMS installed?

Did you get any error while activating the plugin? Also, if you had installed LMS previously, did you uninstall it before installing this plugin?

Yes, installation went just fine but not activating the plugin. I uninstalled the old LMS plugin.
regards/C

Could you provide Volumio logs when you activate the plugin ?

I uninstalled it but I can try to do a new install and send you a log! I´m not at home right now so I probably do it tomorrow.
Best Regards/ C

Sure, take your time. Thanks

1 Like

Oh, btw, after flipping the On/Off switch to activate the plugin, could you give it a while and see if status eventually changes to “Active”? The plugin needs some time to actually start because of Docker. You should eventually get a green “started” notification or red “error” message.

1 Like

Hi Patrick!

Here is my log

Log

after activation there´s a message that says: “Server is not running - this is not normal when the plugin is enabled”

best regards C

Do you happen to have Music Services Shield installed and running?

1 Like

Yes, I do… Do I need to uninstall it?

I suspect that you assigned CPU 3 in Music Services Shield. Docker tries to utilize that CPU but could not because it’s already been reserved.

Btw, is it now not possible to install the Music Services Shield plugin from the plugin store? I no longer see the “System Hardware” category… Would like to see if I can confirm this to be the cause…

It´s there but not in “System hardware”, you can find it in “Music Services” category.

BTW. LMS-docker is up and running after uninstallation of “Music Services Shield”

Regards/C

Right, I see it now. Thanks.

I’ll do some tests with Music Services Shield but I’m not sure if there can be a solution that will allow Docker and Shield to co-exist peacefully…

1 Like

Ok! Thanks for looking in to it. I hope you can sort it out.
Regards/C

OK, I’ve made some changes to the plugin, which should now work with Music Services Shield.

Note:
If you install MSS after LMS, then reboot Volumio after enabling it. If you don’t reboot, MSS will fail to create the shield.

2 Likes

Thanks a lot!
I will try it and get back to you.
Best Regards /C

Now I have tried to run LMS Docker with Music Services Shield and they don´t play together. Wen LMS is running MSS stop working.

Did you reboot your device after enabling both plugins? Could you PM some logs to me?