[PLUGIN] IR Remote Controller feedback thread

Ok, I tried it on GPIO pin 25 today and still got no reaction. To be sure, I wrote an image of a version of Volumio before I installed your plugin on my card and installed it fresh. Still nothing. I loaded the codes for Apple TV, Apple Mediaplayer and Apple Dock on my Harmony, but none worked. When I use the mode2 -d /dev/lirc0 command, I get responses on every key I press, but when I run irw nothing happens.

To be clear, I didn’t change anything in any config file or so. All this should be taken care of already, right?

That would be fantastic. I’m looking forward to updates of your plugin and will try them, when they arrive. I’m still very keen on having IR control over Volumio playback.

Thanks for your efforts so far.

Ok, so I finally got it working too. After finally finding the Odroid Remote codes in the Harmony Database, it worked with these. Man, that was a hard ride, but I’m pretty happy now. :smiley:

What’s making things a little complicated is that I installed the Kodi plugin as well (I need it for multi-channel music) and both players at the same time make the IR control a little unreliable. Either Kodi blocks the signals or Volumio and Kodi both react to the IR signals at the same time. I would be happy to keep controlling Kodi through the USB receiver, but that only works after I de-activated the IR plugin. When I finally find out how to create a folder for Kodi and configure an own set of IR signals (different from the Odroid Remote) I might be done with any workarounds, but so far I’m happy I can remote control Volumio.

Can you tell me which device you have chosen for the odroid remote in harmony remote Database?

edit:
I have found it (hard core ODROID C2)

Thanks.

Michel.

Yes, that’s the one. I had to insert ODROID as brand and C2 as model.

Hi Wolfram, can you please guide step by step how Hardkernal odroid or r oremote works on volumio.

In the end there wasn’t much to it. I use a TSOP 4838 IR receiver and connected the three cables as shown in the pic in my post on page two, but the blue cable got connected to the GPIO pin 25 instead of 18.

I updated Volumio to its latest version (not sure if that’s neccessary), installed the IR plugin and selected the Odroid Remote profile in its settings. I made a habit of restarting Volumio after pretty much every change, no idea if that’s helping, but it sure can’t harm.

If you have an Odroid Remote it should work right away. Ok will Play/Pause, Direction Left and Right will jump to the previous or next track and Direction Up and Down will jump 10 seconds ahead or back. I use a Harmony Ultimate One, so I had to install the codes (Odroid/C2).

Does that answer your question? If you have any specific questions, please ask.

Good luck.

Thanks for quick reply. Is there any idea this plugin works odroid ir remote directly with odroid C2 on board ir receiver.

im about to buy a ir reciever , problem is that i have a rpi3 with a allo reclocker and a piano dac on top… can i mount the ir reciever on the piano dac? will the plugin work with a usb ir reciever or? sorry if this is a little of topic

I coudn’t get it to work with a USB IR receiver on my PI 3. Not sure if that means, that it’s not possible in general.

Ah okay thanks for the reply :wink:

Hi,
Can you please confirm will this plugin works with odroid C2 on hifishield+ DAC and odroid remote. Thanks

Plugin works fine on RPi2 and DAC+, with index.js modified to use GPIO26.
As remote I use a Harmony configured as Odroid C2.
I have 2 issues:

  • plugin need a save configuration action after each reboot or boot after power cut.
    Is there any file for saving the config?
  • volume up or down does not mach with hardware mixer, if mixer settings is set to 10, change in volume is 9 or 11, sometimes 10 as it should. I notice this on web gui.

Thank you for the work, save my time to config lirc.

I tried to use an apple remote and PiFi Digi with the plugin. The digital output works but not the IR. Is it supposed to?

Is there any special configuration needed?

I hadn’t realized there were 4 pages on this thread when I posted. After catching up, I changed index.js line 221 to:

exec('/usr/bin/sudo /usr/bin/dtoverlay lirc-rpi gpio_in_pin=26', {uid:1000,gid:1000},

which is what the PiFi HAT uses. I also removed my dtoverlay=lirc-rpi:gpio_in_pin=26 from /boot/config.txt. Then rebooted.

Still not working. Is it possible that the HAT is bad?

I had the same with the apple remote i did not get him working either i used the odroid remote (i have a harmony one remote and put it on odroid remote) and then it worked.

Another forum member (warter) here has used his own lircd.conf file for the apple remote.

Look what he wrote.

Thanks! It works like a charm!

I have an A1156 remote and if I add my config files under “/ data / plugins / system_controller / ir_controller / configurations /”, I can use it from the UI.
But it would be much nicer if it is part of the installer. Is there any way to add it to the installer?
Random avatar
Warter
Sunday DIYer
Sunday DIYer

Posts: 10
Joined: Mon Mar 13 2017 11:30

Maybe you can replace lircd.conf file from apple remote A1294 for apple remote A1156 maybe it will work.

The downloads for lircd.conf file can be found here.

lirc.sourceforge.net/remotes/apple/

I will update the plugin with the ability to select the GPIO where the receiver is. Could you please let me know any possible GPIO where it might be?

First, as it turns out, I have both an A1156 (old white) and A1294 (silver). Using the A1294, I again confirmed that it works with iTunes on my macbook.

I made a copy of the Apple Remote A1294 directory (called MyRemote) and replaced the original A1294 lircd.conf with the one from sourceforge, changed the plugin profile and even rebooted. Still nothing.

I think its the PiFi. Don’t you?

I first had the infrared sensor
On gpio pin 5 and did not work with the apple remote when infrared sensor moved to gpio pin 25 and then the apple remote still did not work when Odroid plugin selected in volumio and also the Odroid software on my logitech harmony one remote controller then it worked Fine, I get the impression that something is wrong with the apple remote plugin.

I also have my own squeezbox lirc file and it works fine too on gpio pin 25.

Member justBoom wrote this:

You need to use BCM 25 (pin 22) currently as BCM 18 (pin 12) is already used by most I2S audio cards.

pinout.xyz/pinout/amp_hat

and after i modified that, everything worked fine with Odroid plugin but what I also tried did not get the apple remote not working.

It would be very nice that the plugin is updated and that you can randomly select the gpio pins :smiley:

I can assume that gpio pin 25 works with the Odroid plugin, but whatever i try the apple remote i’m not working, it can also be that i see things over the head or i do something wrong.

For the rest I can not control which gpio pin works or not, even though I would like to check that I have soldered the infrared because I have the hifiberry digi + pro on the raspberry pi.
Also, the digi + pro needs some gpio pins for the operation of the dac not every pin is then available.

support.hifiberry.com/hc/en-us/ … d-by-Digi-

By the way, volumio is very good, il love it :smiley: and am very much charmed by the youtube plugin that really adds something to volumio am very happy with it

Keep up with this beautiful work.