Please Help Me Restart Volumio

Volumio Information

Volumio Version: 4.19.86-v7
Hardware: Raspberry PI 3b
DAC: Chinese 8x 1387-based USB DAC

Folks:

I’d appreciate some wise counsel with my dumb problem with Volumio.

I’ve been running Volumio on a Raspberry Pi 3b for a few years now and it has always worked flawlessly. I recently had a power outage and, since then, have been unable to restart Volumio. After trying to reboot a few times I hooked a monitor up to my Raspberry Pi to see what’s up. Volumio seems to boot just fine; indeed, right now the monitor is showing Volumio’s ASCII-start up screen. Volumio’s network connection (Ethernet via a pair of TP-Link power line extenders) is also working just fine according to Fing (avg ping is 29 ms and trace route shows the correct local address). Fing reports the connection between my router and Raspberry Pi is fine. However, I have tried both the local address and “volumio.local” and cannot connect to the Raspberry Pi – I get “Safari Can’t Connect to the Server” errors on my laptop and iPad.

I’m no expert (and have no expertise in RPi or Volumio) and would greatly appreciate some help.

What should I do?

Regards,
Scott

Experience the command line:

$ ip a
In “eth0”, see IPv4 address

Enter the IPv4 address in the browser

NaviGO:

Thanks for the suggestion! I tried it and the eth0 address the RPi provided is the same static address I assigned to Volumio (192.168.1.213). I entered that into my browser and got the same “Safari Can’t Connect to the Server” response. The RPi is on, Volumio is running, Fing says the connection to the router is good and I can’t seem to connect. What the %$@&?

Regards,
Scott

have you tried a different browser, something like google chrome, I also have this problem sometimes with safari browser on an imac.

I have also encountered such drawbacks after ‘insufficient power’ issues on some systems in the past (‘flashlight’ symbol during startup). My diagnose in such cases was that the startup disk got corrupted during a critical read/write task. After a fresh instalment these issues were solved again. Proper power management seems crucial when using Volumio systems. Good luck! Martin

ssh: sudo reboot?
and http:// your ip?

michel8166:

A good suggestion but it wasn’t the solution; I tried Firefox to no avail.

Martinvb:

I haven’t seen any indication of an “insufficient power” issue; the Raspberry Pi boots up just fine and appears to load Volumio just fine. Fing sees Volumio on my network (it appears as standard text, not in half-tones, and Fing can ping it without delays). A software refresh might help but I’m doubtful, if only because the system is up and running according to my monitor. Your thoughts?

Regards,
Scott

dvo:

Another good thought but one I’ve already pursued: I’ve entered “sudo reboot” and “sudo shutdown” each a couple of times, and upon restarting Volumio I’ve encountered the same problem – not findable from a browser (even though it appears as available on Fing).

I’ve typed both “Volumio.local” and the IP address (192.168.1.213) into my browsers. I can’t get to Volumio.

Regards,
Scott

it could be that with a power outage your sd went corrupted you have a backup?

dvo:

I guess it’s possible that my micro sd card was corrupted, though I would again point out that Volumio loads on the RPi and is visible to Fing. I don’t mean to fight you on this, but I’ve put my micro sd reader away somewhere and would have to hunt to dig it out (which I certainly can do). That said, is this a likely possibility? If so, I’m on it.

Regards,
Scott

that some parts load will not say that all load normal.
if you have a backup you could see if it works again with it and will resolve it
the eazy way. other option is if you could get in to it and get a log out of the system.
we could take a look at that to find out where it went wrong.

dvo:

I like the idea of exploring the log before playing with the micro sd card, but I really am a novice: what’s the command for generating a log and what information from it would you need or like to see?

Regards,
Scott

Hi, fact that the system is ‘up’ does not always indicate that all processes are working properly. A power outage is a serious case of acsystem being underpowered, with resulting card or file corruption. Keeping a backup card around is a good suggestion, as these thing happen from time to time.

if you still can ssh in to the system /var/log/volumio.log
if the web browser still works a bit http:// your ip /dev and fill out : Send Log or bug report
copy and paste the log url here.

but why go the hard way if there is a eazy way out…
do you take the stairs or a elevator?
in a 300 story building? you take the stairs?

dvo:

You’re right. I have followed your guidance, refreshed the micro SD card and Volumio is now up and running, apparently none the worse for wear. Not knowing what I’m doing usually results in my taking very small incremental steps, mostly out of fear of really messing things up. Thanks for pushing me in the right direction!

Regards,
Scott

if you have a backup use it most of them didn’t make one and i learned the hard way …
reinstalling many versions with many problems, it’s always good to return to something that worked.

glad i could help you.
best regards,
dvo