Please HELP <>Failed to open “alsa” ……. With the Geekworm DACPi X950 DAC

Hi there around the world,

I’ve just set of my first hardware-DAC

System

1x Raspberry Pi 4 model B (4 GB RAM)

1 x Geekworm DACPi X950 DAC with the chip TI PCM5122 (specs https://wiki.geekworm.com/DACPi)

Installing the latest version 3.173 of volumio worked. The connected USB SSD is distributing the files.

But running the audio, I’ve got always the message:

Failed to open „alsa“ (alsa); Failed to open ALSA device “volumio”: No such device <<

“ST400 DAC (PCM5122)” is chosen as DAC model as the manual from Geekworm is telling, where also is mentioned that the DAC will work with volumio.

Please, is there any experience out there. I would really like to run volumio.

Do I have to pick another DAC in the select menue?! Or do I have to look for the next bin…

Thanks

Klaus

BTW

The hardware is completely running with moode and producing analog audio with the chosen device DeviceRPi-DAC (ChipBurr Brown PCM1794A, InterfaceI2S, FormatsS16_LE, S24_LE, PlatformPi-4B 1.4 4 GB)

Hi, try to use:

  • Generic I2S DAC
    or
  • HifiBerry DAC
    or
  • Melopero DAC ZERO

they are working for me with volumio 3.179 and Rpi4.

The question is: is it a true PCM5122? because it works with PCM 5102.

volumio@volumio:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: b1 [bcm2835 HDMI 1], device 0: bcm2835 HDMI 1 [bcm2835 HDMI 1]
Subdevices: 4/4
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
card 1: Headphones [bcm2835 Headphones], device 0: bcm2835 Headphones [bcm2835 Headphones]
Subdevices: 4/4
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
card 2: sndrpihifiberry [snd_rpi_hifiberry_dac], device 0: HifiBerry DAC HiFi pcm5102a-hifi-0 [HifiBerry DAC HiFi pcm5102a-hifi-0]
Subdevices: 1/1
Subdevice #0: subdevice #0

From the Geekworm Wiki:

NOTE!!
VOLUMIO 3 is not supported temporarily, please use VOLUMIO 2 to play, we are communicating this issue with VOLUMIO.

Great i also have the same issue, three months passed.
Also its a pain as there is no way to download volumio 2.
Help ?