Playlist problems

Im new to Volumio, so probably me but…
I seem unable to delete playlist items, or reorder items in playlists. Is this normal?
Cheers

Volumio Information

Volumio Version: 2.873
Hardware: Pi3
DAC:Cambridge

you must give us more info if we don’t guess your version we could no say any thing.

Its the latest version. As I said, Im new to it, downloaded it yesterday.

I run my playback directly from files in file folders. I do that mostly because I’m an old fart who thinks setting up playlists is a bigger hassle than setting up file structure. If you’re using playlists (they seem to be m3u8 files that get set up whenever I rip stuff), the order should be controlled by the playlist. You’d probably have to edit the playlist to reorder the playback.

I don’t have an answer for why you can delete selections within Volumio during playback. I never do that, since my file structure is sacrosanct (classical music). But I suspect that if, when I queue up a ton of music, I wanted to eliminate some of the pieces, I should be able to do that.

In fact, I just deleted a track that had already played. So, not sure if that’s anywhere close to what you’re trying to do. BTW, I run rpi4 through a Denon receiver. I never bothered to figure out why I should go with DAC. But I may have mentioned I’m an old fart. :slight_smile:

Yeah Im the same about the file structure, but thats not the play order I want. Im used to Foobar and you can reorder the playlist by just dragging items about. Seems volunio cant.
Then Im bemused by the fact that i cant delete playlist items, say if I double up or something by mistake.
There two things to me make volumio a bit useless for me.
I have a similar set up, a Pi3 connected via USB to a Cambridge amp. That has its own DAC. No idea how that DAC compares to the various ones you can get get either for the Pi or as a standalone. Sounds good to me though.

re-ordering of songs you can do in the queue.

Sorry, but I can’t reproduce your problem of being unable to delete items from playlists.
You can reorder in the queue, as @dvo says, by clicking on the album art and dragging to a new position. You should then be able to save the queue back to the playlist (if you want to maintain your new order).

Well, I click on delete, and the item remains. Simple as that really. I assume something is wrong and wont normally replicate.
So, Im not confused about playlists. You cant reorder them, but you have to order the queue, the make that a reordered play list? Why cant you just drag items about in the play list? every other vaguely comparable application can do it. Why not this one? Seems really odd.

I’m afraid @Alan_Cx 's observations is correct
In 2.877 -Playlists – Playlist of choice , you can’t move any item and you can’t remove any item
In the Queue you can move and remove any item
Except the first item !, You can’t move the first item and you can’t move any other item to the first place in the queue (a very old issue :wink: )

In 3.067 You can remove a item in Playlists, otherwise all other issues are the same

Sorry, I carried out my test on a beta 3.066 device by mistake. However, I’ve just tried on a 2.873, and can still delete an item in a playlist. Not sure what can be different from our setups. Is everyone logged in to MyVolumio? (@SonosKiller )

Hi @chsims1

On ver. 2.877 (Rpi) it makes no difference whether i’m logged in or not (haven’t checkt any x86 versions)
Not a big issue for me. I don’t use Playlist so often, but when I do, I pick the playlist up in the Queue and do the moving and removing there and then resave the playlist from the Queue

I think that I have reported this issue a long time ago

Edit1: Remove works in 2.873 X86 , but not moving
The “First item in Queue” issue is also in x86 versions (ver 2.873)

Edit2: But the “First item in Queue” issue seems to be fixed X86 ver 3.066 :yum: