Playlist position NaN/undefined

I had the headphone jack on the pi working but I had messed with so many things that I reimaged my sd card to start from scratch. I installed a hifiberry but I’m just trying to get the normal audio jack to work first before diving into getting the hifiberry to work. However, if I try playing any web radio station, rather than playing anything it says “Playlist position NaN/undefined”. I remember seeing this the first time I installed volumio but I’m not sure what I did to make it go away.

I’ve tried searching for any mention of this message but can’t find anything.


This has been happening to me as well on a random basis. Sometimes it affects only my PC, sometimes my Android phone, sometimes both. A power off reboot seems to reset this issue most times but it only seemed to begin after I ran the update function from within Volumio for the first time. Anyone else have any insight?

Yeah! I’ve the same message in a new fresh volumio installation.

I wasn’t able to figure it out and I never got a response so I was stuck. I haven’t had a chance to revisit the issue in a while but I’ll probably start from scratch again and see what I can find.

I started over from scratch and got the NAN/UNDEFINED issue again. I did all of the updates and then I selected one of the default web streams. It started playing. I then rolled the dice and selected the Hifiberry+, rebooted and playback worked.

I swear I did the same exact steps as I’ve previously done. My only guess is there was an update to the OS that fixed problems I was previously having.

This was with a Pi version B


happened to me now, too… after fresh install.
The first browser works, subsequent ones dont
can operate it using mpdroid but not any other browser from any other PC
(Cookie issue?)
Tried resetting Firefox, tried resetting chrome, only thing that works is the “volume up” button :wink:

did what you said, settings > system > select “hifiberry+” and reboot and all works again.

super strange but works so wont complain :]

EDIT: Now it works on my Windows PC but no longer on my linux PC… can this be Firefox Sync related???

EDIT2: Seems to be cookie/cache thingie… in “safe mode” everything works. How can I trace this issue? Any hints?

using volumio 1.55 on raspi model 2 with hifiberry + DAC

I have been having this problem the last day and 1/2. I usually use firefox but the last 3 times i turned on the raspberry pi3 i get the message. If i add and play the song/songs, it would play but not info on play list or playback. I just tried chrome on the same computer and volumio is working normally so far.