Playback settings - Allo DigiOne and Khadas Toneboard

I have an RPi 3B and an Allo DigiOne HAT.
The Rpi is running Volumio 2.729. It gets power from the usual mini USB socket.
The Allo DigiOne sends SP/DIF signal to a Khadas Toneboard with latest v1.04 firmware.
Music is held on an SSD connected to one of the RPi USB sockets. It is either in 16/44 flac or m4a formats.
The RPi gets internet via WiFi.
Questions -
In settings / playback, the output device is set to “Allo DigiOne”. If I turn I2S to “off”, this option disappears and I can only select “snd_allo_digione”.
When using a Allo DigiOne, should I2S be on or off? I think I need I2S to be “on”, but when I select this, a second box appears below I2S on/off labelled “DAC” and the only thing that works here is for me to enter Allo DigiOne as the DAC - which it isn’t. There is no entry for Khadas Toneboard in the list of DACs.
The Khadas toneboard with the latest firmware is supposed to allow hardware volume control. Under “volume options” the only mixer types are “none” or “software”. Probably because Volumio doesn’t know that a KTB is connected.
Have I got the correct playback settings for my configuration? Is there anyway that Volumio can control the KTB hardware volume control when the KTB is not linked directly to the RPi, but is linked via the Allo HAT?
Finally, I would really like to run the BruteFIR DRC software in Volumio. I have installed the PlugIn, but the setup screens do not look like the ones in the Wiki. For now I have disabled the Plugin.
Thanks
Paul

Hello Paul,
I have exactly the same configuration.
I2S must be on
Dac Model on ‘Allo DigiOne’.
Save and restart
The dac Khadas will never be visible and the volume control in the Volumio interface will no longer be active.
To get the best out of it, the dac Khadas must be powered by an external 5V/3A power supply on contacts 1 (+) and 21 (-) of the card.
A 75 ohms rca cable is recommended between DigiOne and Khadas.
LeGroove