Playback setting with raspberry pi and Topping e30

I am a newbie. Just connected my new Topping e30 to the Pi via USB. Then connected the e30 to my receiver via coax cable. Pi is running in volumio. Earlier setup of pi to receiver via HDMI was working OK.

Question is on volumio playback setting. At Audio output set to USB:E30 and 12S DAC off, dac displays zeros and no sound. At 12S DAC On, the E30 is not listed among the DAC models. Tried some models but with no success.

What am I doing wrong?

From another E30 thread - Playback settings:

RPi 4 > Topping E30 - Volumio v2.882

DSD Playback Mode: DSD Direct
DSD Auto Volume Level: Off
Volume Normalization: Off
Audio Buffer Size: 2 MB
Buffer Before Play: 10%
Persistent Queue: On
Playback Mode: Continuous

Mixer Type: Hardware
Mixer Control Name: E30
Default Startup Volume: Disabled
Max Volume Level: 100
One Click Volume Steps: 10
Volume Curve Mode: Natural
MPD Clients Volume Control: Off

These settings also work for me (RPi4->USB->E30->RCA->Denon amp). Try them if they will work for you. I think it shouldn’t matter which output you are using from the E30 to your receiver