Playback issues with Spotify

I am constantly having issues with Spotify, possibly syncing? I will select Spotify and either no folders will show up, or when I select a folder, it is empty. And even when a song is shown and want to play it, the playback shows it as playing, but not true. Sometimes it works just fine. I have loaded the latest version, and still have issues. This is getting very frustrating. I am using pi2b.

At first glance, it sounds like a networking issue. Are you connected wirelessly? If so, can you try it wired?


i’m experiencing the same problems: Since one week i believe, volumio does not honour changes to my spotify Playlists. Previeously this worked perfectly.

Kind regards from munich, and… I love Volumio!

Good call. I tried wired, and it seems the problem is resolved, though that doesn’t help me with my setup. So I assume it is an issue with my Edimax dongle. is there a better solution for wireless?

Edimax usually works well with the Pi. Perhaps it is a poor signal? If so, you could try a wireless repeater. I use a Netgear WN3000RPv3 wireless extender for those hard to reach places (it amplifies as well as repeats the wifi signal, I believe).

It appears the wifi is not the issue. I have the same problem with another pi setup I have at work. It’s wired to a fiber network. Could there be an issue with the new version of Volumio and pi2B with Spotify? I have no issues with the external hd’s I am using both at home and work.


sorry, connecting wired instead of WLAN didn’t work: My personal playlists of Spotify are definately those I saved about 2 weeks ago. All my new and changed playlists I see on my Spotify client do not appear on Volumio.

Any guesses?

Kind regards

I do not think it’s related to the new volumio version: I fell back to Version 1.55 and it’s the same: The personal playlists are not updated on volumio. Since this is the case for almost exactly 2 weeks I rather think it’s an issue with the Spotify Interfaces.



Update: It seems to work again! But why?