Playback delay through DLNA / no sound through AirPlay

Hi, I have been having playback problems since installing volumio 2.041 on a Pi with a HifiBerry DAC - grateful for any help.

I am streaming from a NAS through DLNA. Each time I start or change a track there is a delay of 20+ seconds before the track starts. Tailing /var/log/volumio.log suggests that volumio is looping through a start/stop cycle (see below). While it’s doing this the track on my remote will get to 0:01 seconds and then jump back to 0:00. Once it’s started, which can take anything from 20-60 seconds, it seems to plays OK.

However, when I try and stream through AirPlay, it get no sound at all. Similarly, it will jump between 0:01 and 0:00 a couple of times on the remote and then look like it’s playing, but I get no sound. And nothing gets written to the volumio.log file. I’ve had AirPlay working on this setup before, but not today…

Suggestions welcome - thanks all.

2017-01-16T20:47:02.177Z - info: Starting playback through UPNP
2017-01-16T20:47:02.184Z - info: [1484599622178] CoreStateMachine::setConsumeUpdateService mpd
2017-01-16T20:47:08.289Z - info: CALLMETHOD: audio_interface upnp stopUpnpPlayback [object Object]
2017-01-16T20:47:08.296Z - info: CoreCommandRouter::executeOnPlugin: upnp , stopUpnpPlayback
2017-01-16T20:47:08.299Z - info: Stopping playback through UPNP
2017-01-16T20:47:08.303Z - info: [1484599628300] CoreStateMachine::setConsumeUpdateService undefined
2017-01-16T20:47:14.431Z - info: CALLMETHOD: audio_interface upnp startUpnpPlayback [object Object]
2017-01-16T20:47:14.439Z - info: CoreCommandRouter::executeOnPlugin: upnp , startUpnpPlayback

I wish I had the answer for you but I have the same issue and it’s driving me nuts. I have JRiver with DLNA on a server and I have connected a RPi3 with HiFiBerry Digi over wifi. I get a 13 second delay every time I change tracks. Someone suggested it may be a UPNP issue with Volumio. Seems to make sense but I don’t know what to do about it. I tried using Moode Audio instead of Volumio 2 but I don’t have Moode up and running yet.

Good luck.



I’m new to Volumio. I’m having exactly the same issue. Theres a big delay between selecting a track on the dlna controller and it playing. Using asset upnp server, bubbleunpn server and kazoo as the controller.

I’ve tried it with rune and other renders and all works just fine.


Hi guys,

Did either of you get a solution to this delay? I have the same setup whereby I’m using jriver on a server and volumio is setup as a dlna zone on a pi3. I’m using wifi throughout and have no problem playing tracks direct from volumio and there’s no delay changing tracks when using the volumio web interface. When using either the jriver app directly to control the music or one of the remote control apps ( I’ve tried Gizmo and Eos ) I get a 10sec delay.

It’s really frustrating as the rest of the system works flawlessly.

Any help would be appreciated.

Cheers, Mark