PINE64 et flac

Bonjour à tous,

Je possede un pine 64 2GB avec volumio installé dans une carte sd de 16GB. Mon probleme est que j’ai un son affreux avec les fichiers flac.
Je peux les lires mais il y a des gresillements. J’ai essayé avec plusieurs albums en flac meme souci.

Mais pour le mp3 ou le webradio ca fonctionne très bien.

Quelqu un pourrait il m’aider (si une personne comprends le francais desolé)


My French is not very good, but you are saying that you have a Pine 64, running Volumio (which version?), with sound problems with flac files (crackling??)? Are you using an external DAC, and if so, which one?

Hi chsims1,

Thanks for your answer. I’ll try to speak english. Yes i use a pine64, the version of volumio is 2.118.

My device is connected with an amplifier marantz. MP3 sound is good but not flac. I do not understand why.

Yes sound flac crackling .

Ok, you have a pine 64 and awfull sound with flac files. Basically it works, but not without issues and this counts for several albums.
But with mp3 or webradio pine works very well.

I presume you are using the 3.5mm jack, you would have those issues because of the onboard DAC.
The only real solution is to use a good external DAC (usb Audio).

That said, there is a way to improve it for some files, but you will not get it to play absolutely everything.

You would have to edit /ect/mpd.conf
Change the line with “44100:16:2” to “44100:24:2” (without the quotes), I could play most of my flac that way.
It’s not perfect as mpd then resamples, let me know how it goes.

OK, posts crossed, sorry. So, your Marantz has an onboard DAC, can you tell us which Marantz it is?

Please try the “/etc/modprobe.d/alsa-base.conf” file, add the following line and reboot.
options snd-usb-audio index=1 nrpacks=1

Unfortunately the problem persists even after changing the conf files. The flac does not work and slows down even my pine64.

For the moment I read mp3 files ca me suitable. So much worse for flac files.

What model is your marantz and what sort of DAC does it have.
Perhaps we can experiment with mpd.conf setting.
It would also be good to know what bitrate your flac files have.

EDIT: Could you also do

lsusb -t

For me paying flac file is ok. I’m adopting an usb DAC ( … &order=ASC) . I works fine for me.