PI 3B and HiFiBerry DIG2 Pro, Volumio 2.917

In case it helps others:
Set DAC to DIGI+ Pro but needed a PI reboot for it to be recognised.
If I knew more I might mod the dacs.json file with;

** ## {“id”:“hifiberry-digi2-pro”,“name”:“HiFiBerry Digi2 Pro”,“overlay”:“hifiberry-digi2-pro”,“alsanum”:“2”,“mixer”:"",“modules”:"",“script”:"",“needsreboot”:“yes”},**

Further to the above I have found a reboot did not always solve the problem. Looking on the HiFiBerry website I found the problem could be that the PI’s audio had not been turned off and config.txt could need that instruction. The info was here:
My resulting config.txt now reads like this and seems to be reliable.
config_DigiPro.txt (308 Bytes)

Spoke too soon, not working again !!
Now Volumio has a blank screen for Playback Options, something seriously wrong.