Pi-2 and volumio 1.55 very unstable

Hi there,

I have just built a Raspbery Pi-2 with IQaudio DAC+ controlled by Volumio 1.55… After building the SD image, the setup boots fine, I change the DAC
reference, play music all good, even the Android Voumio WebApp works OK…

I then tried that crappy Sound@Home App, and it seems the ‘auto config via LAN’ completely destroys something in the Volumio image.

I have rebooted twice, the Volumio startup sound comes out of my amp HOWEVER no interface via browser nor Android!

I plugged in my HDMI to see the Pi-2 logon scripting, it seems to look all ok ending at the $ prompt, however after a few seconds I get some sort of EXT4-fs error count…?

Are there any commands I can run from the shell to restart the failed services or whatever is causing the issue?? Thanks

maybe you should reflash your sd card. (easiest way)

Similar problems as above…

Initially had the thing working then tried a re-boot. My troubles then just began…

startpar returns FAIL but the GUI is functional for about 1 min before it (the GUI) drops… Start-up screen reports:

“Unable to handle kernel NULL pointer dereference at virtual address…”

P.S. Have re-flashed the SD card many, many, times…

P.P.S. Are any of the earlier versions of Volumio stable for RPi2?

no only 1.55
what power supply do you using? what sd card do you using?

Thank you for the follow-up…

Power supply: I have two - 1) 5V 2A SMPS; 2) 5V 3A Linear supply (have tried both)
Cards: I have two - 1) Kingston SDC10/8GB; 2) Samsung EVO/16GB (have tried both)

FWIW, all combinations of PS + Card run openELEC on the RPi2 OK (this was done as an exercise to verify hware OK)

I had Volumio 1.55 running stable for a day then it seemed to fall apart after an attempted restart… Countless attempts since incl. card re-flash without success. Noticed a few others have been having same/similar issues reporting same/similar error messages.

Evperience: First time RPi / linux user here (not counting 2x SqueezeBox Touchs that i have). Have built many windows boxes for audio over the years…

I’d love to help debug also - as soon as my backordered Pi2 arrives :sunglasses:

Me too… (Pi2 Volumio 1.55)
Unstable is so elusive and difficult to quantify. I have found that my WiFi connection (Edimax EW-7811un) exhibits many dropped Rx packets and is often very unresponsive. I found many conflicting symptoms, so… I finally went for a strong solution, maybe it would help, maybe not. Here it is:

sudo apt-get update sudo apt-get upgrade
It takes upward of ten minutes to complete.

I am thrilled with the result. my Pi2 Model B is rock solid. YES!

Just wondering if any Volumio 1.55 + RPi2 users are NOT having stability problems?

Presumably, if the failure rate is high then a fix is not too far away or does it generally take weeks or months for new platform + software to “settle down”…?

Would appreciate any advice.

I noticed some extra posts, so thought I would do an update…

I re-flashed my card and it seems stable but stay away from the ‘Sound@Home’ App AT ALL COSTS it breaks the whole distro!!

I have since be powering it quite nicely using an Anker 14200MaH external power pack! I also use some crappy Chinese 2.1 Amp 5v power supply.

Hopefully a new update of Volumio makes it rock solid!

Mine has been rock solid. No stability problems whatsoever. My setup is as follows:

I’ve tinkered a bit, so it’s not exactly pure 1.55 any more, but nothing that should affect stability. (The main changes are to resize the root partition on the Micro SD card, to uncomment “album_art_names” in /etc/minidlna.conf and to improve security by changing passwords, regenerating ssh keys and switching from password to key-based login over ssh.)

Thank you for your post. It gives me some motivation to persevere and try a few things… Not sure what as openELEC & Raspbian run without a hitch. I have tried a few cards… Maybe a different power supply…?

Been running a Raspberry Pi 2 with HiFiBerry DAC+ and a Samsung 32GB Evo MicroSDHC plus a Apple iPad charger without any problems for the last few days

My RasPi 2 (volumio 1.55) has been running stable for a week now. (Except some tinker-induced re-flash on Thursday that I don’t want to talk about :wink:). However I had an initial stability issue that was similar to what you describe with a smaller/cheaper power supply. Currently the RasPi is running on a 3.5 A unit that came with an old phone of mine.

Short: Try a bigger power supply.


My HW config is the same as Mike’s except power supply - but i also use 2A power adapter.
Only noticable problem i hv got with Ralink WIFI adapter - finally it get burned and RPI is on wire :slight_smile:
There are a few glitches on webui but except that everything works stable from 3,5 weeks.

try sudo rpi-update to update RPI firmware.

Hi there,

Since my initial post I have been running Volumio with my RPi2 with IQaudio DAC+ and powering via an Anker power bank quite successfuly. I avoided that dodgy Android app that crashes it, not sure if it still works, don’t care!

I also managed to add a Wifi dongle, and using the powerbank, have an impromptu potable DAP! LOL!

I just rec’d my new Pi2 and IQaudio DAC+. I have a 2A wallwart PS. After some initial fiddling, I got everything working through headphones on the DAC+ jack. When I moved it to my stereo (unplug and reboot), I get nothing from the DAC+. After many reboots, reflashes using img from this site and also IQaudio’s site, Volumio now cannot ’ find’ my DAC+. When I go to Playback>Audio Out, the only choice is ALSL, no DAC+.
Any ideas? Any command line way of verifying DAC+?

SOLVED! I downloaded the new 1.55 ikg from IQaudio and after a few hick-ups on first boot up (date set to future??, no lost & found), everything worked like it was supposed to and had STAYED THAT WAY. I cannot say enough about Gordon’s help in this. Not onlly did he email back and forth several times, he was ready to ship me a new board (to US) to try to see if it was an issue with the DAC+.