Odroid C2 / Volumio / Mojo - Crackling

Hi all
I am experiencing a crackling sound (much like surface noise on an LP in rather bad shape), using the following setup:

  • Synology NAS / MinimServer as Music Server
  • Bubble UPnP on a Sony Z3compact as Control Point
  • Odroid C2 / Volumio (2.03) as Renderer
  • Chord Mojo connected to Odroid C2 via USB
    I start the Odroid C2 fresh when I want to play music.
    Sometimes playback is fine.
    Most of the time however I get a crackling sound when playing back music. Sometimes restarting Volumio helps, but most of the time not.
    I would be grateful for any suggestions.


Same as mine
No such issue on Pi3

Please help

HAPPY NEW YEAR to all of you!

I have tested the same setup with a Denon PMA-50 through its USB DAC input instead of the Mojo. No crackling.

I could not swear to it, but it seems to me that the problem started with Version 2 of Volumio. I don’t recall it being there with the Beta of Volumio 2.
Also, the crackling issue also occurs during the startup sound during the boot of Odroid / Volumio. That would point to a problem in the interaction of Odroid / Volumio and Mojo, not at the NAS backend.

I suspect that the problem was introduced somewhere in the kernel change between the Beta and the regular Volumio 2.

Interesting find! I will try to find a stable pre-release from before 20161024 as after that we used the newest C2 kernel because if it’s HiFi Shield 2 driver. I will make a link available (things are a bit slower here because of annual leave).

Ok, I have to correct this, the first commit of the new kernel was done on September 13th, so could you guys please test the following pre-release image and report if the usb audio problems were there or not? It uses the first kernel we committed for a C2 version, really appreciate the testing!
Link to version 0.981
(Remember, it has tons of old errors but playback should work)

Will do so tomorrow

Hi Gé
Just ran the test with the old kernel. Pristine sound without any crackling.
Maybe I am imagining it, but it seems to me interworking between BubbleUPnP and Volumio is also more fluid and smoother with the old kernel. Less waiting times when selecting something.

I’ll email you a link to a dev image in a few minutes, it uses the current HK kernel with a patched usb driver.

Thanks, Gà
The dev image solved the issue.

I reverted the only patch I could find on the usb driver which HK did between the 3.14.29 and the 3.14.79-84 kernel.
Nice to hear it works so far, I hope to find more people willing to test the image with other usb dacs the C2 had difficulties with.
I will also get in touch with HK to hear what that patch was meant for. It must have had a reason, but seems to cause regression in our case.
More testing with other usb devices (disks, wifi dongles etc.) is also needed to make sure my patch did not brake something else.

Hi, I’m searching to solve an annoying crackling with the Odroid C2 + built in dac of Parasound Halo Integrated (ESS Sabre32 9018K2M). I’ve tested this pre-release image. 44.1/16 sounds great, but everything over that have pops and clicks. It get worse at 192/24. The affinity fix suggested in another post won’t solve the problem either.

I have the same issue on the latest official build with c2 on Oppo 105D.

@gkkpch I have been using the rc2 builds from your website and I don’t recall the jitter/crackle noise. Could you please send me the dev build to try?

@cnnn: you have a PM

You have a PM

Thanks! @gkkpch All good with pre-release image and the dev image!

I’m having major crackling with my setup as well using the Web radio stations:

Odroid C2
Volumio 2.03

USB Dacs tested:

Dragonfly Red
Resonessence Herus+

I also tried version 0.981 but Odroid C2 won’t boot. Get stuck with a purple screen.

I can also test with a Denon PMA-50 and Apogee Duet (iPad/Mac) but I have a feeling I’ll have the same issue.

Thanks in advance for your help.


I reported the issue to Hardkernel and this has now been confirmed up as a usb driver issue.
Version 0.981 may not work for everyone. This is fine, it was just to verify that the old kernel did not have any issues.
Do not waist any more time on it, meanwhile I had enough reports that the old kernel was still ok.
Version 2.030 obviously suffers serious issues you all have reported.

I will try to get a new version published soon with a temporary fix.

I will open a new thread for the USB driver issue, do not add anything here.