Node.js takes more than 100% of CPU plus WebUI not reachable

Volumio Information

Volumio Version: 2.672
Hardware: Pi 3B
DAC: IQAudio DAC Plus
PSU : 12V 5A
Case : Audiophonics with RPi Powermanagement (Power Button Function)
SD Card : SanDisk Ultra 128GB

I am using volumio for a few months now and encountered with the almost actual version 2.8?? several issues related to WiFi (disconnects, no reconnect). That got disappointing by time !!

So I decided, based on several threads on different websites, to go back to a version 2.6?? hoping, the WiFi problem does not occur. Now, the installation did boot up to the command line and the WebUI was reachable to make some settings (RPi Touchdisplay Plugin, Audiophonics Case with RPi Powermanagement) and it did great. Ok, for a few moments. After a reboot, only the command line shows up on my touchscreen, no hotspot, no WebUI. SSH’ing into the Pi, realising the node process takes up to more than 100% CPU… whaaat ?
WebUI not reachable, even “ifconfig” shows me an IP, received from the DHCP !

To be honest, I used the Logitech Mediaserver and the Squeezeplayer on that hardware before. That worked way more stable ! But, you know, sometimes its time for something new :wink:

My question here is, how do I get that thing working again ?
I am able to work on the command line but without further information, that would be a mess to find the problem by myself…
Normally, I would reinstall everything (write a new image to the sd card) and start from the beginning. But that cant be a solution…

all the best

Without any logs it’s hard to say, what the reason is. But maybe you did not wait long enough after the initial start of Volumio so the data partition did not get expanded and now disk space is too low. If that could / should be the case you could create a file “boot/resize-volumio-datapart” with

touch /boot/resize-volumio-datapart

and reboot. Then the data partition will get expanded to its maximum size.

Thank you for your reply and hint. Tried that, saw the result of resizing the datapart but still the same behaviour. It did that before, after installation. So I am sure, the datapart was already setup correct.

That did not solve my problem…

I can reproduce this. After writing a new image to the sd card, everything works fine. Resizing works and the player works. Installed the Touchscreen plugin and the Audiophonics plugin, still working. When I press the Power Button short for a controlled shutdown, the player turns off. After turning it on again (with the Power Button) the only thing I can see on the touchscreen is the command line and like I wrote in my first post, no WebUI even with IP from DHCP.

I did not test the reliabilty of WiFi, as this is at this point a minor thing to know. First of all, the player should completely work !

Still trying the 2.6 as stated in post #1. Does anybody know of a bug in this situation ? 2.8 is not interesting for me as I get those weird WiFi problems… by the way, I use two players at the moment. One with the 2.8 (and WiFi problems) and one with 2.6 (hoping, it would work better).

hi martin how did you install an earlier version, i have 2.8? and nothing but problems similar to yours, but no one will tell me how to roll back firmware. any tips or links.

what do you mean with roll back ? just download an earlier version and install it with e.g. etcher from balea on an sd-card. thats it. plug it into your rpi and power it up…

take a look here : Older volumio versions .img files - Help and Support - Volumio

thank you I have asked this question several times several ways and no one answers, are you in Australia

I am going to have to reinstall i have tried it on ethernet and 5ghz wifi and it just stalls not happy. cheers

No, sorry. “At the other end of the world”, germany :wink:

back to topic : I guess I figuered it out. The Audiophonis Plugin for supporting the Hardware Power Button causes the problem. When I install this plugin, after a reboot nothing works any longer. no WebUI…

I tried it with the 2.6 and the 2.8 version on a RPi 3B.

Could any admin here manage to initiate the removal of this plugin from the repo ?

yes, that is discusting… now I am happy not to have a subscription for the paid version in any way.

I am getting really tired of this version and will install a few versions earlier and see if the problem goes away. cheers

Installed 2.671 on both of my RPi players… in that short period of time I had no problems with lost WiFi. How about you ? Did you get it handled to install an image on an sd-card and use that in your player ? If not, let me know…