No "Wireless Network called Volumio" on PiZero

Hello there.

I took a PiZero (No Wifi/BT), updated it to latest Firmware …
(“Linux raspberrypi 4.4.50+ #970 Mon Feb 20 19:12:50 GMT 2017 armv6l GNU/Linux”),
… wrote “volumio-2.175-2017-05-16-pi.img” like Raspbian to an microSD-card and booted the PiZero.

All I get is a Volumio-prompt on the HDMI-out, but I can´t see a Wifi called “Volumio” (neither on my
smartphone nor on my tablet), even after waiting 30 minutes.
The USB-Wifi-Sticks worked well in Raspbian (RT5370 and RTL8188SU) and are listed with “lsusb” after
logging in and “ifconfig” shows that “wlan0” is “” (tested with both Wifi-sticks).

I am confused … maybe I don´t understand the englisch docs:
Some minutes after booting the PiZero should provide a Wifi-network called “Volumio”. With my smartphone
I sould connect to this Wifi, log in and can then configure the PiZero with my smartphone - right?

But why does this not work with me and my PiZero?
Where do I get wrong?
How can I integrate a PiZero with a USB-Wifi-stick into my network?

Best regards,

Not all USB wifi dongles are capable of, or need different drivers to produce a hotspot. If you can’t see a ‘volumio’ network, then perhaps this is your situation … try searching the forums, I forget which ones do & which ones don’t. You report that you have a wlan0 interface at, which is the correct address for the volumio hotspot … that is a bit confusing, but perhaps Volumio thinks that the hotspot creation was successful.

How to proceed further? If it was me then I would see on the off chance if the dongle will work in “normal” (non-AP) mode. Try editing ‘/etc/wpa_supplicant/wpa_supplicant.conf’ to contain details of your home network, reboot, and see if it get a dhcp IP address assigned correctly. Don’t edit ‘/etc/network/interfaces.’ Failing that, a usb to ethernet adapter or a different dongle?? Good luck :wink:

Edit: I don’t know how familiar you are with wpa_supplicant.conf, so if it helps my file is:

ctrl_interface=/var/run/wpa_supplicant network={ scan_ssid=1 ssid="home" psk="yourpasswordhere" priority=1 } network={ ssid="home" key_mgmt=NONE wep_key0="yourpasswordhere" wep_tx_keyidx=0 priority=1 }

I had issues with the pi zero and wifi that are now solved, I would recommend if possible try a different microsd card- I have 2 new cards 1 of which stubbornly refuses to work with volumio. Also ensure that there is good wifi coverage where your pi is- I had to reposition my router for a better signal and now volumio works everytime.

Please do not change kernel/firmware.
Currently Volumio is on 4.4.9; it may evolve soon, but will then be extensively tested.

Is there a very specific reason you need more recent kernel?
Please re-image Volumio with an unmodified baseline version, so that we can better help.

Not sure RTL8188SU is supported out-of-the-box on Volumio.
Can you report what you get from lsmod command?
RT5370 is reported working as Wifi client, unsure for Hotspot (@chsims1 can you confirm, you may have one of these I think ?).

Not all USB wifi dongles are capable of, or need different drivers to produce a hotspot.
I thought standard devices/chipsets work “out if the box” like they do in Raspbian
or other Raspi-“Software”. But OK, I solved it:

How to proceed further?
I turned it into a normal Wifi-client which gets an DHCP-adress from my router.
(Took a long time as I have to use a german keyboard to code in the US layout of Volumio
an could not use SSH and cut&paste as no network was established.)
Finally I succeeded - but I was cheering too fast: When I put this address in my browser
I reveive a dark screen with a "shadow-UI"of volumio and a turning white circle in the middle.
“sudo apt-get update && sudo apt-get dist-upgrade” didin´t help to solve this.


So: What do I have to do else? The circle is turning for almost one hour.

Please do not change kernel/firmware.
I just have one PiZero, and I use it for different projects. And for some projects you need the most
recent firmware of the PiZero.
If I now do a “uname -a” i receive this “Linux volumio 4.4.9+ #884 Fri May 6 17:25:37 BST 2016 armv6l GNU/Linux”-
My “4.4.50” was made on a Raspbian-SdCard, maybe this didin´t came out clearly.

Not sure RTL8188SU is supported out-of-the-box on Volumio.
It is working in LAN and with internet on Volumio, but not in AP-mode as i alreday stated:

volumio@volumio:~$ lsmod Module Size Used by cpufreq_stats 4040 0 xt_REDIRECT 1547 1 nf_nat_redirect 1911 1 xt_REDIRECT xt_tcpudp 2455 1 iptable_nat 2224 1 nf_conntrack_ipv4 14594 1 nf_defrag_ipv4 1817 1 nf_conntrack_ipv4 nf_nat_ipv4 6306 1 iptable_nat nf_nat 17370 2 nf_nat_redirect,nf_nat_ipv4 nf_conntrack 97429 3 nf_nat,nf_nat_ipv4,nf_conntrack_ipv4 ip_tables 12473 1 iptable_nat x_tables 18811 3 ip_tables,xt_tcpudp,xt_REDIRECT cfg80211 499234 0 rfkill 21397 2 cfg80211 snd_usb_audio 142269 0 snd_hwdep 6447 1 snd_usb_audio snd_usbmidi_lib 22439 1 snd_usb_audio snd_seq_midi 5262 0 snd_seq_midi_event 7671 1 snd_seq_midi snd_rawmidi 23663 2 snd_usbmidi_lib,snd_seq_midi snd_bcm2835 23163 1 snd_pcm 95441 2 snd_bcm2835,snd_usb_audio joydev 9194 0 r8712u 177928 0 snd_seq 58506 2 snd_seq_midi_event,snd_seq_midi evdev 11650 0 snd_seq_device 5266 3 snd_seq,snd_rawmidi,snd_seq_midi snd_timer 22396 2 snd_pcm,snd_seq snd 68368 11 snd_bcm2835,snd_usb_audio,snd_hwdep,snd_timer,snd_pcm,snd_seq,snd_rawmidi,snd_usbmidi_lib,snd_seq_device i2c_bcm2708 5740 0 bcm2835_gpiomem 3823 0 bcm2835_wdt 4133 0 uio_pdrv_genirq 3718 0 uio 10230 1 uio_pdrv_genirq i2c_dev 6578 0 fuse 89800 1 ipv6 367575 62 squashfs 32128 1 overlay 32464 1

So: I have access with Wifi/SSH, but I still don´t get a “usable” Volumio-menu
in the browser (see screenshot above).
The PiZero was rebooted, but the issue is still there.

On PiZero “Ifconfig” states, but my Wifi-Router states “” for it?!
Anf from Windows SSH is working with “”.

OK, but please be fully aware you are running on a configuration that is not intended for Volumio, so you may experience very particular bugs, that no-one with standard configuration can replicate/ help to solve.
Do you have to run all projects simultaneously (with NOOBS or al.)?
Can’t you use different SD cards for different projects, each with its proper configuration? (at least to initially get things going & be familiar-enough with Volumio before attempting uncommon setup).
Anyway, the more “standard” you can stay the better: not sure we’ll find a solution.

lsmod shows system loaded kernel staging R8712u driver for your RTL8188SU dongle, and this information confirms only wifi Client is possible (AP mode (Hotspot) not supported).

Black screen is often an illustration of Volumio application crash and restart loop.
It may be due to many unexpected things, including not letting very-first boot complete for long-enough (8mn at least).

This is most probably due to the fact Volumio initially tries to create Hotspot, and that’s the default IP it uses for that. We know your dongle does not support this mode, so this must fail somewhere, but in some unexpected manner maybe…

Can you get the log file: sudo journalctl > /tmp/log.txt check this log.txt file does not contain personal information (such as passwords, etc), and then copy-paste into pastebin or similar, and provide link so that we can examine it.

Can’t you use different SD cards for different projects,
I never said that I am using one card only: I use a different card for every project.
I changed the hardware-firmware, what is nearly the same as a BIOS on a PC.
The Volumio-Edition was not changed by me.

I took another sdcard, wrote a clean Volumio installation and used another
Wifi-Stick, now with RT5370-chipset: There was no Wifi at all as it was not recognized
(but working fine in Win10). Hmmm…

So once more: Wrote a clean Volumio installation and used another Wifi-Stick, this
time with 8188EU-chipset. And finally: It worked out-of-the-box, providing a
Hotspot “Volumio”, coonection via Android-Browser “Opera Mini” failed, but
Android-Browser “Firefox” worked fine: Connected to my home-LAN and
until then working fine.

Thanx for your help so far.

Here are the Ebay-Link to the USB-Hardware I am using with the PiZero (No Wifi/BT):
Wifi-Stick (about 1,-€) -->
USB-Audio (about 1,-€) -->

If you are in Germany or living near the border: The Supermarket REAL is selling
the Bluetooth-Speaker with included Powerbank “Videoseven SP6000” (which is most likely
the same as “Speedlink TONOS Box” in Black or White for below 10€, but prices vary withtin
hours from 8€ to 18€, so watch often. If you let it deliver in one of their markets and pick it
up there you are not charged for shipping.

My config until now:

  • PiZero (No Wifi/BT) ~11€
  • USB-Hub 4 Port ~2€
  • USB-Wifi with 8188EU ~1€
  • USB-Soundcard ~1€
  • Bluetoothspeaker with included Powerbank ~9€

Volumio with PiZero(NoWifi-BT) and Speaker with Powerbank (using AUX-in).jpg

And now: Watching the sunset listing to RockRadio1… :smiley:

Glad it finally worked.
BTW USB Hubs are known often affect operations with some Wifi dongles: some won’t work reliably (or at all) behind any (or some) hubs…