No Wifi on Cubox-i4-Pro under 1.2beta

Have a number of bugs to report. Unless I’m directed otherwise, I’ll assume they are best dealt with in separate topics. So will post a thread for each. Here goes…

On a Cubox-i4-Pro, running Volumio 1.2beta for Cubox-i, I cannot connect with wifi. After clicking the “save changes” button, each attempt gets the following message in response for Interface wlan0:

wlan0 IP address: — NO INTERFACE PRESENT —

Wired ethernet - Interface eth0 - works just fine. No issues pulling FLACs off a NAS as evidence of that. Plus the radio stations work.

The problem is not with the Cubox hardware either, because if I swap out the SSD card and boot off an Android image instead, wifi works just fine. I have tried this with both “WPA/WPA2 - Personal” and “No Security” settings under Volumio. Same negative response for both. FWIW, the Android image was validated as working with “WPA2 - Personal” security.

Hope that helps. :slight_smile:

Hi scolley,

if you have typed in Router data and password and have pressed ‘save changes’ you after a while see as you described ‘NO INTERFACE PRESENT’- am I right?
Then try to reboot afterwards and it should work. I am only using PI but I think it’s the same. After saving changes, reboot is necessary.


Thanks Robert. It is all as you described. Except I had not rebooted afterward. And to be clear, not only have I been entering the WiFi SSID and Security Password, I’ve gone to the trouble of going into the router’s configuration pages, and copying and pasting those strings from the router. So there’s zero chance of my misspelling either. Plus - as I indicated in my first post - I took the Volumio Beta1.2 MicroSD card out of the Cubox, inserted a MicroSD with an Android build on it, and was able to quickly and successfully configure it for WiFi access. So the box works, and I am able to configure it. When it works.

But following your advice lead to an adventure. After rebooting, I could not access the device at all. Not over WiFi, not with it plugged into my ethernet network. Yet as it powered up, my Dragonfly DAC went through its normal sequence of colored lights, indicating - at any rate - that my DAC was happy. But there was no getting to the device through its webpage.

That happened when trying to configure WiFi for “No security” security option. So I re-flashed the card, and repeated the experiment. Same result - able to get to the device webpages (over ethernet) until I tried to configure WiFi for “No security”, and rebooted. As before, the device webpages became totally unreachable.

I reflashing again, and tried the “WPA/WPS2 - Personal” security option, and rebooted. This time I could get back into the device webpages. But only over cabled ethernet. Still no Wifi.

In these various reboot, reflash, try to connect adventures, I noted two different values for “Interface wlan0” at various times. They were:

wlan0 IP address:
- and -
wlan0 IP address: — NO INTERFACE PRESENT —

So having last tried to use the “WPA/WPS2 - Personal” security option, and rebooting, I’m back in the device network configuration webpage. But oddly now the DHCP dropdown box has the value “Nothing selected” showing. Stranger still, if I click that dropbox to indicate that I want it to use DHCP, there’s nothing to select. The only option available for selection is the value “Nothing selected”.

Something with Wifi in this build is broken. I guess I’m about to reflash. Again.

Hi scolley!

Just try another wifi dongle. I wasn’t able to connect through wifi after powering down and starting again when using my logilink device. Then, after I’ve plugged in edimax EW 7811 Un and reconfigurated, it worked.

But generally there is something not quite perfect with wifi implementation in this version. But you could experiment with alternate dongles.


Thanks metalrob. I assume your experiences with changing dongles was on a different hardware platform? Because the wifi hardware/firmware is built right into the Cubox-i4-Pro. (As a side note, it was on the i3 too. But I noticed today that Solid-run is no longer selling the i3’s, and that WiFi/Bluetooth functionality is now a $12 option on the i2’s)

That’s why I mentioned the Android. All I did was swap the Volumio microSSD for one with Android, reboot, enter my SSID and Password, and BANG! Working WiFi. Did not require any dongles. So Volumio is not recognizing - or not appropriately using - something that is already there.

I think I’ve got some WiFi dongles somewhere, and could give that a try. But the fact is that until the Volumio software can make use of the on-board hardware, there’s a bug, and it does not really “support” the platform. Or not fully anyway. Plus not using WiFi for now is not really a problem for me, as I’ve got wired ethernet coming to my audio rack where the Volumio Cubox has been placed.

Thanks for the suggestion though! :smiley:

Hi all,

i have the same problem with the cubox-i4-pro - no wlan0 interface.

Might it be some kernel device driver modules missing?

When i look for loaded modules under android - where
the built in wireless device is running seemlessly -
i can see “brcmfmac” and “brcmutil” modules being loaded.

I can’t find theese modules anywhere in the volumio’s “/lib/modules…”

May be compiling and loading theese modules helps.


See my post at solved-wifi-cubox-t1117.html for one solution to the cubox wifi problem.

Thanks for your work to create a workaround for this problem in the offical release! Please see my post in your thread.

Unfortunately for me, the “fix” corrected the WiFi connectivity, but broke Volumio’s ability to work with my USB Audioquest Dragonfly DAC. Maybe others - with other DACs - will not have that problem.

i tried with two other DACS and the “fixed” kernel.
The dacs are not recognized anymore