no wifi after 1.5 upgrade

I have upgraded to Volumio 1.5 but now my wifi will not work… no wifi light on the Wi-Pi and no wifi connections shown as available.
Everything else works great!!!

(this same setup with the Wi-Pi worked fine under ver. 1.4)

How can I get Ver. 1.5 to recognize my Wi-Pi?

Raspberry Pi B+
Wi-Pi wireless dongle
Dragonfly DAC
Volumio 1.5
several USB thumb drives


Please look here?


I have one of the Realteks too, itdidn’t work either under 1.5.
Although it and the Wi-Pi both worked under ver. 1.4

The hardware that worked under 1.4 hasn’t changed.
It must be the new Volumio 1.5
I’m not very good at Linux programming, is this the only fix?

Raspberry Pi B+
Wi-Pi and Realtek 8xxx wireless dongles
Dragonfly DAC
Volumio 1.5
several USB thumb drives

Please update to Volumio 1,51 … p/download and let us know . :wink:

Ver 1.51 has same problem, does not recognize the Wi-Fi dongles. ALSO NO HDMI OUTPUT.

Can no HDMI be a clue?

Rune audio works flawlessly. Audio, Wi-Fi, HDMI, web & MPD interfaces, but
doesn’t support hardware volume control like Volumio does.

I would really like to get Volumio working.

Thanks again…

what wifi dongle do you use exactly?
maybe you must install the drivers on top of volumio

Both of these work with ver 1.4… and again, theres no HDMI output

First is the WiPi

A 802.11n compliant wireless client for your Raspberry Pi installation
Wireless Standards IEEE 802.11n, IEEE 802.11g
IEEE 802-11b
Wireless Speed 11n : Up to 150Mbps
11g: Up to 54Mbs
11b: Up to 11Mbps
Frequency Range 2.4~2.4835GHz
Wireless Transmit Power 20dBm (Max EIRP)
Modulation Type OFDM/CCK/16-QAM/64-QAM
Wireless Lan Modes Ad-Hoc Infrastructure
Wireless Security 64/128 bits WEP
Support Operating System Linux Debian 6

Second is the ADAFRUIT 814

The Adafruit 814 WiFi module works with the Raspberry Pi and is effortless to set up requiring only an available USB 2.0 port.
Supports a higher data rate of up to 150Mps when used in conjunction with wireless 802.11n
Plug-and-play setup and installation is a snap
Mini WiFi module with up to 3 times farther range than an 802.11g

Thanks for reporting this. This is probably due to wi-fi modules not loading properly. I’m investigating on that. Will report something soon

Same problem here…Using the TP-LINK TL-WN725N V2 which uses the 8188eu.ko driver. Worked fine on 1.4x.

Driver loads and kernel seems happy with it:

pi@volumio:~$ dmesg | grep 8188
[    7.225086] usbcore: registered new interface driver rtl8188eu

and on hotplugging to wifi all seems well:

[ 623.739937] usb 1-1.2: new high-speed USB device number 7 using dwc_otg [ 623.850920] usb 1-1.2: New USB device found, idVendor=0bda, idProduct=8179 [ 623.865841] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3 [ 623.889343] usb 1-1.2: Product: 802.11n NIC [ 623.901816] usb 1-1.2: Manufacturer: Realtek [ 623.914334] usb 1-1.2: SerialNumber: 00E04C0001

But it won’t connect to DHCP server…


Mine doesn’t even show the available Wi-Fi connections.

And again, no HDMI output. So can’t use my extremely novice abilities to troubleshoot it.

OK. I fixed it. I downloaded 1.51 and installed the 8188eu driver but it still wouldn’t connect to the wireless after several reboots. volumio.local was not working either despite eth0 being connected and working. So I ssh’ed in thru the eth0 IP and noticed that /etc/network/interfaces wasn’t showing any wlan0 interface, only loopback and eth0. So, I created a new section in /etc/network/interfaces. For me that was:

iface wlan0 inet static address netmask gateway wpa-ssid ASUS-2.4 wpa-psk blahblah

sudo ifup wlan0

and it worked. From a browser I connected to and setup the wireless to use DHCP. Volumio then overwrote my /etc/network/interfaces, including a wlan0 setting which now looks like this:

[code]root@volumio:/home/pi# cat /etc/network/interfaces
auto lo
iface lo inet loopback

auto wlan0
iface wlan0 inet dhcp
wireless-power off
wpa-ssid ASUS-2.4
wpa-psk blahblah

auto eth0
iface eth0 inet dhcp

and after a reboot all was well. I dunno why it wouldn’t see wlan0 by itself, 1.4x did I’m sure, but whatever, all’s well that ends well.


That’s amazing, and totally over my head :confused:

ah sorry - it’s meant for michelangelo really. The point is that 1.5x doesn’t seem to write the wireless setup properly. The /etc/network/interfaces config file is Page 1 stuff if u have any experience in Linux wireless - which is generally a pain.

Maybe it’s bcos of my netmask (8 not the usual 24) or the fact that my ‘bought-latenight-from-amazon-aftertoomuchbeer-with-a-dazed-click’ TP-Link wireless adapter does not have an opensource driver that is built into the Linux kernel - a savage mistake.

Whatever, speaking generally, almost any software on a Pi will be running a version of the Linux OS and you can enter it using ssh (secure shell). This piece of magic allows you to interact with the Pi’s live operating system over the network from your own PC and mess about with the configuration. It is often essential to connect using wired first (which always works), ssh in thru the wired connection, and then get the wireless drivers loaded and setup the wireless configuration. If you’re going to use a Pi then the ability to use ssh is a must, IMHO. Yu then don’t need a monitor/HDMI. I use Manjaro Linux as my desktop OS, and it’s a doddle to ssh from Linux to Linux, but I think from Windows you can use “PuTTY” or something. Google “ssh into Linux from Windows” . It’s not so hard, and once you’ve got the command line of your Pi, over the network, on your screen, then yu can start tinkering. And then the fun begins. Well, it’s mostly fun….


Thanks! I will give it a try :wink:

Too complicated for me to try to learn how to ssh with windows.

All I wanted was a simple, quality, music server…

I found this which seems straightforward enough…

But it’s odd that yours worked under 1.4 and not under 1.5. It is possible that the developer has removed some wireless drivers to lighten things up - but such a move would be very unusual.

Given that your device previously worked, and now does not work, and coupled with the problems I had with my device which worked in 1.4 but didn’t work 1.5 without editing a config file, then it is likely that something is amiss with how Volumio configures it’s wireless settings in 1.5. But in order to get proper support you’ll need to post the exact device (name/model number) that yu have - then we can first see if you have a built-in driver, or not, and go from there…

But maybe more significantly, I see you also say

So, are u saying that when you power up the Pi with the the HDMI plugged into a known working monitor/TV that you see abs nothing? No PI logo? Boot up screen or anything? In that case it’s certain that your SD card image is borked and did not build properly. SD cards are far from 100pct reliable. Try building the image again …maybe try another SD card.

Volumio is worth peservering with…seems easily the best Pi audio solution out there.


I may have been at fault on the Wi-Fi. I was looking for a list of Wi-Fi networks to select from. There were none visible so I thought the Wi-Fi adapter was not working. I manually entered the Wi-Fi network name and password and after a minute bingo…connected to Wi-Fi. Is this normal?

I have 2 complete setups. Both Raspberry Pi B+'s, Dragonfly DACs, Wi-Pi brand Wi-Fi USB’s, various Sandisk and Patriot micro MMCs.

The problem of no HDMI on Volumio still persists. HDMI works fine on BOTH systems using Noobs, Rune, & XBMC. Volumio has no HDMI on both systems.


Same problem for TP-LINK TL-WN725N V2
(Worked fine on 1.4)

finally: “signal strenght is wrong”

from web gui:

from iwconfig:

installing driver, config it took too long and hard for me :blush: