No tracks in DLNA browser

Volumio Information

Volumio Version: 2.882
Hardware: Pi 4B
DAC: Tentlabs b-DAC (USB)

So this is the story.

I once bought a Olive O4HD music streamer.
It looked like an ideal package as it had dedicated built-in storage (2 TB) and a slot to transfer a CD (ripping) to that storage.
This was topped off with a network connection providing internet access (for retrieving track info etc.) a DLNA server and option to control it from an app.

Fast forward about 10 years.

Olive has changed big time and now focuses on totally different products.
There have been no updates for years to the O4HD and the app disappeared from the stores.
My iPad4 was the last device on which the app was available but that one died 2 years back.
The touch screen on the device was never a good option as it’s an older type responding to slowly.

Time for a change.

After reading up on the matter I hatched the following plan.
To make my collection usable again I would as a first step introduce a volumio to my setup and connect it to the same DAC as the O4HD as it has an USB option available for that.
Volumio should at this stage get the files from the O4HD and play them back to the DAC.
At the second step if I succeed in getting the first working the Pi would be equipped with a SPDIF hat (Allo DIGIONE SIGNATURE).
As a third and final step my music collection would move from the O4HD to a NAS (preferably containing a built-in DLNA functionality) and the O4HD taken out off service.

Current state of project.

I purchased some hardware (Pi 4B with 8GB - 7¨ TFT touch screen - 32GB micro SD - SmartiPi pro case) put it together and configured the SD card with the latest available version of Volumio.
Connected the Pi to my home network (wired) and DAC.
Volumio started and I can access it bij pointing a browser to http://volumio.local/.
DAC was recognized straight away so configured that as output and installed the Touch Display plugin.

Then thinking I was good to go I went to Browse → Media Servers → Olive.
Here I’m able to choose between several options like artist - album - playlist and all these options display the contents of the O4HD at this point.
However when I get to the point where you normally would expect track information it just says¨No items¨.
This behavior is independent of which route you take or which track and will appear sooner or later.

Things I tried already.

Reboot of the Pi and power cycle on the O4HD.
No change.

Update of Volumio.
None available.

Instead of using a browser try the same action on touch screen or using the official Volumio app.
All three result in the same No items message

Using a generic DLNA app (actually I tried VLC - Lumin - BubbleUPnP - Hi-Fi Cast) on my tablet (Lenovo C330) to try connecting to both Pi and Olive devices.
All four are able to browse the contents of the O4HD including tracks info.
VLC failed to identity Volumio as a target (renderer) the other three found it without a hitch.

Using the test apps playing a file back.
All four do play on the tablet.
Lumin Bubble and Hi-Fi cast also succeed in playback using Volumio as renderer.

As it looks from my point of view Volumio is not handling the data from the onboard DLNA browser correctly.
Results obtained by the performed tests show that the track information is definitely available from the O4HD.
Also I have proven that the data format (which is standard FLAC) stored on the O4HD is compatible with the Volumio renderer.

I just don’t see what the problem is regarding the track information or how to fix that.

Any suggestions?

Not an anwer to your problem, but do you really need to go down the DLNA route? It’s just more software layers between your music files & playing them. If the answer is ‘yes’ then fine, and forgive me for my post …

…otherwise why not simply share your music folder on your NAS using cifs or nfs?

Like I said there currently is no NAS.
Only the Olive device (and that only has a cifs share for imports) with DLNA functionality.

I must say I’m a bit disappointed.

Almost 2 months and I got 2 replies.
The first got deleted before I actually had a chance to read it.

The second is the unavoidable if DLNA isn’t working don’t use it.
That unfortunately isn’t the solution I’m looking for.

What’s the best way to proceed from here?
Should I make an official bug report.

in witch browser are you looking volumio or your tv?

I’m not exactly sure what you’re talking about.
There never was a TV involved nor will there be in the future.

Maybe this post should be in another thread.

1 Like

you can’t browse it on volumio but you can browse it from a tv…

I can browse from apps on a Chromebook.
I never tried if it works from my TV.

I definitely don’t want my TV involved in music playing

1 Like

if it has dlna it could tv is eazy for testing. < your volumio ip >:8200 let you see the devices on the pi

MiniDLNA status

Media library

Audio files 0
Video files 0
Image files 0

Connected clients

ID Type IP Address HW Address Connections
0 Sony Bravia 192.168.1.105 XX:XX:XX:XX:XX:XX 0
1 Generic UPnP 1.0 192.168.1.122 XX:XX:XX:XX:XX:XX 0

-1 connections currently open

Hi snhel5, it is always disappointing when you don’t get replies to posts asking for help. Please remember that this is a Community forum with people from the Volumio Community helping out if they have the knowledge. They may not, and hence you get no reply. Devs do look in at times, but if you are sure that you have a bug that is reproducible, then please report to ‘issues’ on Volumio’s Github repo.

@chsims1 this is how @gvolt thought me how to use it…

The purpose of the miniDLNA plugin is installing and running a DLNA server on a Volumio OS.

If I understand the OP correctly, @snhel5 neither has the miniDLNA plugin installed nor even tries to run a DLNA server on Volumio, but wants to use the DLNA server of the Olive O4HD as a music source in Volumio.

So to me it appears, snhel5 doesn’t have an issue with using Volumio as a DLNA server, but as a DLNA renderer. The problem seems to be, that the contents of the Olive DLNA server can’t be browsed (properly) using Volumio.

ok @gvolt i understand now what he means tnx for explaining what he meaned.
i only know what you thought me about dlna and how it work with volumio.

In essence that is exactly the problem I’m facing.

I will do as @chsims1 advised.

The issue is very reproducible as bubbleupnp always gets correct results and Volumio never does.

I’m having this same issue. Volumio is not finding any tracks from my omv server which is pushing out dlna. I upgraded to volumio 3 and have had problems with Spotify and dlna since upgrading. I never had any problems with volumio version 2.

I did file an official bug report (twice).
It has been more than six months and no one even looked at them.

In the meantime I reinstalled the device with the latest version of Moode.
That has a few issues as well but they don’t block the basic functions (play music).

Just try for yourself and decide if you like it or not.