No sound in v1.4 with USB DAC

My setup is a RPI (256mb version) a pcm2704 based usb DAC and a ta2020 amplifier with pioneer bookshelf speakers.
This was working nicely on Volumio v1.2, although I did have some stability issues. I therefore upgraded to v1.4, and am very pleased with the overall stability of the system and everything now seems to work. EXCEPT that I cannot get any sound through the DAC. I have the choice in the GUI to use the DAC or the PI’s 3.5mm output, and in fact the DAC option is chosen by default when I boot up with the DAC attached. The sound works through the 3.5 jack on the Pi. But no sound at all when I use the DAC. The DAC is working, as I do hear sound on v1.2.

I have previously raised this problem here:
and here:

but I have had no joy with getting this working so far, so I am hoping that by posting here I may get some helpful responses. Many thanks in advance for any help to get this working.

Does anything seem to play but you can hear no sound?
First try to disable mixer, with mixer none.
Then type alsamixer and see if volume is muted (I think it’s not…)
Let me know

I have the same problem. Upgraded this morning from 1.2 to 1.4. The system is playing - the wifi dongle is downloading radio steams - but no usb sound. I tried to disable the mixer, tried the software mixer, tried the alsa, rebooted the whole system between config changes. I also tried the different I2S drivers. But no success.

I’m using a RPI rev B and a ES9023 DAC.

Hi michelangelo, and thanks for your reply. It does look as though it is playing something, and when I disable the mixer, as you suspected, the volume is not muted in alsamixer. What could the problem be?

Just wanted to give this a bump. can anyone advise on how to fix this issue please?

I’ve just tried this with a Behringer UCA202 and it works perfectly. I wish I could get it to work with the PCM2704, thought. I’d be really grateful for advice.

I’m able to repro the issue with a pcm2704 dac. I just picked it up and installed volumio for the first time today. too bad :frowning:.

Yup, I got no sound from my usb dac.

Just to say that the DAC is working on v1.41! I don’t know what has changed, but it worked straight away. Thanks for the new version :smiley: