No sound after update 2.799

Hello,
I just upgraded to the latest version, and since then I have no sound anymore.
The music libary is found, I can select music, and volumio indicates it is playing, but no sound to be heard.
No changes were made and I came from a perfectly working system.

Anyone any help?
Peter

OS info

Version of Volumio: 2.799
Hostname: volumio
Kernel: 4.19.118-v7+
Governor: performance
Uptime: 0 days, 0 Hrs, 27 Minutes, 34 Seconds

Audio info

Hw audio configured: HiFiBerry DAC Plus
Mixer type: Hardware
Number of channels: 2
Supported sample rate: 44100 48000 88200 96000 176400 192000

Board info

Manufacturer: Raspberry Pi Foundation
Model: BCM2835 - Pi 3 Model B
Version: a02082 - Rev. 1.2
Firmware Version: Apr 27 2020 14:35:17 - 3a8f1793b758d6fb7f375edaa260e069ecd34c88

CPU info

Brand: Processor rev 4 (v7l)
Speed: 1.20Mhz
Number of cores: 4
Physical cores: 4
Average load: 4%
Temperature: 48°C

Memory info

Memory: 992940 Ko
Free: 41032 Ko
Used: 951908 Ko

Storage info

INTERNAL storage - Size: 5068Mo Used: 985Mo Available: 3807Mo (75%)

https://community.volumio.org/t/no-sound-out-of-hifi-berry-dac-with-volumio2-2-799/40057/6

More info here

I got it working. Its actually quite simple, it looks like the enumeration of output devices is not working.
Edit the /etc/mpd.conf file.
Find the audio output section
change the device “hw:1,0” - it was 2,0 before.

it worked for me.

On my fresh 2.799 image, in the audio_output section for alsa, I have

device “hw:0,0”

Are you saying change that to “hw:1,0” then?

Well, I am only saying that it worked for me. You can always try;)

It seems it needs a reset of the /boot/config.txt as well.
The change of /etc/mpf.conf file was not enough to solve the issue.

My original file was manually updated as follows
dtsparam=audio=off
dtsparam=i2s=on
dtsoverlay=hifiberry-dacplus

The update seems to add it own parameters (and some of these are double)
I cleaned the config.txt file an rebooted. Everything is now up and running (again) and the update seems to be applied correctly

Please see: No sound out of HiFi Berry DAC + with Volumio2 (2.799)

I’m also stuck with this problem – no usable system for neary a week now. I applied the fix recommended
in the thread above (changing the final entry in /boot/cmdline.txt to snd-bcm2835.enable_headphones=1 and restarting) but it had no effect. aplay -l reveals that the Hifibery is now card 2:

card 2: sndrpihifiberry [snd_rpi_hifiberry_dacplus], device 0: HiFiBerry DAC+ Pro HiFi pcm512x-hifi-0 [HiFiBerry DAC+ Pro HiFi pcm512x-hifi-0]
Subdevices: 1/1
Subdevice #0: subdevice #0

/etc/mpd.conf has the audio going to:

device “hw:1,0”

which seems right. But there is still no sound. This seems to be the crucial error-message:

error: Cannot get ALSA Volume: Error: Alsa Mixer Error: amixer: Unable to find simple control 'Analogue',0

(I have no peripherals attached – touch-screens or whatever).

Sigh,

Jim

To solve this problem temporarily at least it was enough for me to edit /etc/mpd.conf so that the audio output is specified thus:

device “hw:2,0”

and restart mpd (having reverted to the version of /boot/cmdline.txt originally supplied by volumio). Which doesn’t accord with how I thought ALSA numbering works, but I suppose something changed.

Jim