No sound after restart with v2.555

Hello, It’s the first time I use Volumio.

On RPI 3B (1Go Ram), Raspberry power supply 5V-2.5A, MicroSD 64Go Class10 SanDisk
add fresh purchased HIFI PiFi DAC+ (I2S port) card.

pushed last v2.555 image with dd CLI command under my ubuntu laptop

As I add ethernet line to my room, I disabled wifi, set SSH access.
Audio Output: Output Device: Audio Jack, I2S DAC: On

Fist it work fine… I was surprised to must connected my speakers on RPI jack out instead HIFI DAC+. Speakers was powered by RPI usb. Radios Works, so I add folder as mentionned by @buzink in

[code]mkdir /music
chmod 777 /music
ln -s /music /var/lib/mpd/music/USB[/code]

it works,
after hours, we stop music and turn off speakers… and it doesn’t work anymore.

As speakers sounds a pick, I switch it to external power supply. Speakers works with a smartphone, connect back to RPI… no more sound.

When click “Play” on web-UI button, it stays a triangle.

After severals tests, I run “Factory Reset” in web-UI and it works back! Re-setup /music and push back some music, it works. I upgrade the OS (apt update && apt upgrade) and install vim-gnome.

Shutdown (Show setting->shutdown) yesterday evening.

This morning, power on and before run, I add some musics to /music folder.

Run speakers… try to run… triangle stays again an no sound.

In /var/log/volumio.log, I have

error: Upnp client error: Error: connect ECONNREFUSED

last OS upgrade return an error:

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = (unset),
	LC_ALL = (unset),
	LANG = "fr_FR.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
debconf: delaying package configuration, since apt-utils is not installed
(Reading database ... 24843 files and directories currently installed.)
Preparing to unpack .../firmware-ralink_1%3a0.43+rpi6_all.deb ...
Unpacking firmware-ralink (1:0.43+rpi6) over (20161130-4~deb8u1) ...
dpkg: error processing archive /var/cache/apt/archives/firmware-ralink_1%3a0.43+rpi6_all.deb (--unpack):
 trying to overwrite '/lib/firmware/rt2661.bin', which is also in package firmware-misc-nonfree 20161130-4~deb8u1
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Your DAC is not officially supported, that might be the thing…
However, turn i2s off. Restart your PI, Turn i2s on and select hifiberry dac+ . Do not touch the output options.

Let me know if that works

Hello, I did what you suggested, no more sounds:

I never have sound from PiFi DAC+ jack connector, only Raspberry jack, is it normal?

Thanks for your help.

Sorry, as you can see in my previous post, I misunderstanding the toggle switch.
Regarding toggle switch, this link is interesting: … will-chan/

Anyway, I reset again volumio, made some tests without PiFi DAC+, understand correctly the settings and put back DAC+, put settings correctly and It sounds with jack connected to DAC+ jack connector. Run all the day correctly.

This morning, I would like to add a webstation. As I can’t connect in ssh mode, I activate it… and I change password.

And Commons buttons lost theirs names (I stayed in english)!
I launched a search on password change and found … tart_Guide which speak about hotspot. As I have wired connection, I remove wifi and hotspot … and commons buttons names come back !!

So I selected a radio in “Volumio Selection” and add it in Favourites.
Then I edit /data/favourites/radio-favourites

At this point, my issue is when I select it, it return “Error failed to decode”
… SOLVED: find webradio flux at … caise.html
and add in My Web Radios

to be continued.…
Capture du 2019-03-10 12-29-05.png

I also have the same issue with NO sound after external DAC restart… with different DAC Hardware (SMSL M100) and Volumio Version: 2.729 Mar 2020.

After I turn off the external DAC and turn it on again, Volumio (on Raspberry Pi 3B+) no longer plays music.

A Volumio restart is required in order to re-enable music playback.

If this is a shortcoming in the underlying OS, does anyone know which (if any) commands are required to re-enable the external DAC without a reboot ?