No sobwoofer mode piano 2.1 after update to 2.502

Hi All,

after the update i am not able to get the Subwoofer mode 2.1 running.
I use a rpi3 with Allo Kali and the Allo Piano 2.1.
Do anybody have a idea what i have to do?

Thanks in advance!

Hi All,

has nobody a idea what is wrong with my system.
I already switched back to the older version but i really would like to use the current one.


Hi jochen, I ll look into your issue in about 10 days. Sorry can’t do it before

Hi Michelangelo,
Thank you!

Michaelangelo, any update on this topic? We have holiday week in the US and my system sounds weak without sub. If not, can I get the 2.457 download somehow?

Thanks and keep up the great work.


Same setup and issue here!
I did a factory reset to get back to previous version.

here you find older images

Michelangelo: Is this being resolved? Next update? I also have the Kali+Piano and don’t want to update until I know things work as intended

Sent from my iPhone using Tapatalk

Hi Guys we’re receiving feedbacks that Subwoofer mode does not work with latest update. We’re investigating, sorry for the trouble.
We’ll do it asap but really short on time during this time of the year


Anyone try 2.513 pertaining to the subject issue?

The subwoofer works in the last version but the volume is not controlled by the master volume so when the volume is 0 the subwoofer stays on the same volume. Get stuck to the max2play for now…

Sounds like it’s time to put some priority on this issue.

Sent from my iPhone using Tapatalk

Time for what?
Guys, it is holiday season here, most of us do this voluntarily (and with pleasure), but please bear with us.

Hi Volumio developers. Can you give some indication whether this problem is being worked on, or if Allo Piano 2.1 product is not a focus any longer. Last month I felt it was right to give a donation first before asking, so here I am.

Many thanks and keep up the great work.

Yes, Piano 2.1 seems a bit neglected. I gave up and put my unit in dual mono mode plus rewired.
Dual mono works fine, and subjectively, slightly better sound.

Sent from my iPhone using Tapatalk

Hello Volumio development team. Any new information on this subject? Just want to know if I should continue to wait, or pack up and move on. I’d like to update and try the newest Volumio product, but not if my system will be unusable.

Same to me

I think is very strange that in the last release (this week) still the same problem I bought Piano 2.1 due to subwoofer output, I can’t believe since vers 2.502 nobody solve it and another extrange thing is that it´s impossible to manual upload DSP files because directory is root not volumio user

We found the issue with Piano 2.1 and it has been solved, you will have it in next release

Hello Michelangelo

Thank you so much for your information, can´t wait for the new update :smiley: with subwoofer modes fix

By the way, I tried with no luck to manually upload DSP subwoofer modes by SSH, I get Permission denied Is it possible that /lib/firmware now is for user root and not Volumio I tried with Volumio pass Volumio and no permissions I also tried User root and pass Volumio but not works

Thanks in advance

Best regards and congratulations for the great job at Volumio

I finally solved my issue

I want to thanks to allosupport for his help

I give this little guide for anyone who has same problem

1- Start Volumio go to Network sttings and take note of the IP for example
2- In the browser write you will be promted to a cautive web the you will see active SSH button push it (note that no changes happen)
3- Start Putty and start session at User Volumio Password Volumio
4- Write sudo wget … rmware.tar
5- When ask for password use Volumio
6- Then sudo tar -xvf piano-firmware.tar -C /lib/

You will see this


7- Done! then you will go to subwoofer mode 2.1 and 2.2 working perfect, hpe this guide help to others

volumio great.jpg