No internet access (?)

Hi all,

I have installed Volumio 2, in a raspberry pi 3 (I have also tested in pi 2), and it seems that any function requiring internet access is not working. Examples, I cannot install plugins (when I press PLUGINS it displays the pluggins screens for a second and then directly returns back to volumio.local/playback), WEB radio is not working and SYSTEM/check updates is not responsive.

Moreover, when I play music from Browse/Music Labrary/Nas etc, it is fine. However, when I press Browse/Albums, after a second it jumps to volumio.local/playback (similarly to PLUGINS example above. )

I have checked both wired and wireless connection without success.

Any ideas?
many thanks

This is the damn dhcpcd, that with some routers, fails to resolve to default gateway.

Could you please post the content of your /etc/resolv.conf file?

here it is:

Generated by dhcpcd from eth0

Google nameservers

domain Speedport_W_724V_09071602_00_006A

/etc/resolv.conf.tail can replace this line


could you please comment the line:

domain Speedport_W_724V_09071602_00_006A

(it will become)
#domain Speedport_W_724V_09071602_00_006A

save, (don’t reboot and try)

sudo ping

let me know

I did it and it pings normally.

and do you access ressources now?
Can you resolve server names with host command?

I had situation where host command worked whereas volumio internet ressources (webradios, updates, plugins) were not resolved and failed…

Well, it seems we have a similar issue. I still do not have access to resources.
Moreover, host gets proper reply

You may check this for hack-ish resolution until bug is identified and fixed.

I do not have regular access to affected setup on my side (ISP specific), so it’s hard for me to give Michelangelo detailed & interactive feedback on this. Maybe you can help more in tracking this.

EDIT: in that case make a copy of original host file to revert to std one for diagnostics

I am happy to help if I get somewhat detailed instructions.
the iterations would be rather slow, thought, since I only have an hour or so in front of the pi each evening.

\etc\hosts file is backed up.

Dunno if you resolved the problem, but something you might want to try: could be that ISP does not like Volumio’s default Google’s DNS…
Under ssh, you can type:

sudo mv /etc/resolv.conf.head /etc/resolv.conf.tail and then reboot.

To see if it really works, you may want to revert hosts file to the initial one (and keep a copy of the modded one in case).
If it does not solve your problem, you may reverse the command:

sudo mv /etc/resolv.conf.tail /etc/resolv.conf.head

I can not test anymore this ISP situation, as the affected buddy finally changed ISP, and now is happy camper (was not the only reason, but was part of it!).

Let me know if by chance this works.

Dunno if you resolved the problem, but something you might want to try: could be that ISP does not like Volumio’s default Google’s DNS…
Under ssh, you can type:

Code: Select all
sudo mv /etc/resolv.conf.head /etc/resolv.conf.tail

and the reboot.

That worked for me many thanks for your help, have been banging my head against a wall for weeks. :smiley:

Thanks for the report: happy it worked.
Good news is that this change has been rolled-into Volumio build, so next versions should not suffer from this anymore.

Finally managed to try this fix after having a modified Hosts file that mostly worked. Had to add some of the IP addresses of the web radios that I wanted to listed to. Was becoming a bit cumbersome.

This fixes everything :smiley:

I have not changed the router (BT Home Hub 6), would seem that BT just did not like the settings.

Will be great when it is included in the next release.

Thanks to everyone for the effort they put into Volumio.