No HDMI sound with Volumio on Cubox-i2


I have installed Volumio (v2.129) on my Cubox-i2 and now I don’t get sound over HDMI. The SPDIF output I’m not sure of as I don’t have any compatible devices.
Now i logged into to the cubox and tested if i a soundtest would give sound

aplay -D pughw:1,0 Noise.wav # from /dev/share/sounds/alsa

and this also doesn’t work. I have my monitor connected to the same HDMI so that is no problem (display works).

When i run a aplay -l i get the following output

card 0: SPDIF [Integrated SPDIF], device 0: S/PDIF PCM snd-soc-dummy-dai-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: imxhdmisoc [imx-hdmi-soc], device 0: i.MX HDMI Audio Tx hdmi-hifi-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0

I also ran a speaker-test, but then i don’t hear anything.

if I try to select the device by looking at the output of aplay -L
then if I select hdmi I get an error saying

ALSA lib confmisc.c:1286 Unable to find definition 'cards.Integrated_SPDI.pcm.hdmi.0:CARD=0,AESO=4,AES1=130,AES2=0,AES3=2'

and some other errors

When I tried to play the specific noise file

aplay -D plughw:1,0 Noise.wav  #again from from /dev/share/sounds/alsa

I hear a very minor click in my speakers when it starts.

I’m not very acquainted with Linux/Debian, so I don’t know where to seek the problem now.

Hope you guys can help me,

with kind regards,

I have a small update based on another post
when I checked the following:

sudo alsamixer -D hw:1

I get an overview of 4 channels i.e.:
HDMI Support Channels
HDMI Support Formats
HDMI Support Rates Front
HDMI Support Rates Rear

I cannot change any of them and they are all set to 0.
When I set the volume options to Software in the volumio web-interface I get an extra channel that is

However this doesn’t make any sound come out my HDMI screen audio jack.
Just to be sure I tested this with a laptop sending audio to the screen and this works as expected.

with kind regards,