No audio when trying to run Volumio as a VM in UnRaid 6.9.1

I do realize the VM support is not really a thing here until there is more a of a demand for it. With the new video that SpaceInvaderOne did for adding Volumio as a VM in unraid, that time could soon be approaching.

My issue is simply that I dont have sound when trying to use volumio across my local network from UNRAID to a windows machine using a chrome browser. Everything else works fine in that the VM boots and the share for my flac audio was added with no issues. If there is some sort of troubleshooting guide or if there is anyone here that uses this as a VM in unraid, I would love to hear from you as I am stumped at this point.

For now, I am just using my motherboard audio (passed through via UNRAID VM) and no DAC for this and it is passed through with no errors. The video I watched for this worked for him, so I am not sure what I have done differently. The motherboard is an ASUS x399A for AMD Threadripper processors. I am using chrome to access Volumio (latest version) but have no sound at all. I’m sure its either something newb on my part or something super easy to correct (hopefully).

I will gladly supply whatever info that is needed if I haven’t given enough and many thanks for stopping by! If there is no support for VM’s, no big deal. I will just use something else. :slight_smile:

Not sure if people can help, or it’s even related to Volumio. Seems there are a lot of reports on sound issues, running a UNRAID VM and Realtek audio.

Thank you for the reply.

I don’t have this issue with any other VM nor do I have any issue with having sound (when needed) other than Volumio. I have also tried to pass through a video card with its corresponding audio controller and have the same problem. No sound.

While it may not be Volumio, I dont appear to have this problem anywhere else but with Volumio.

Yes, there would probably be room for improvement, but we never focussed on VMs and have no intention to do so…
We simply don’t have the resources for it, there is too much else already to take care of.
If community members want to help with their experience, then are very very welcome.

Cheers - Gé

If I bought a DAC of some sort, would this solve the issue I am having? Im just not sure how to move the music from my server to {everywhere else} using Volumio even with a DAC as I feel like I would still have the same problem. I would be more than happy to buy something if it meant that I could get this to work.

I have a hard time understanding how anyone would actually want yet another baremetal PC taking up space, using way more power than needed, and adding heat and noise to run only an audio streaming service. It seems grossly unintuitive and clunky. Maybe for a Pi?

That being said - I like Volumio and want it to work. So if a DAC would work, then please let me know what I need to use and how to implement it. Many thanks!

I would like to give you advise, but I am not familiar with this type of VM. As a DAC is not the cheapest thing to buy, you might try with some cheap `USB speakers. At least to verify if the USB through put is stable/working.
But to be honest I would advise to use something like a Pi, to minimise all kind of unwanted side effects

I installed volumio on an rPi4 and it works. I dont have a DAC but I am probably going to buy one. Any suggestions are most welcome! My next question is how to get audio to things like my phone and my soundbar for music on my projector as this whole audio part is illusive to me for some reason.