NFS mount options not properly implemented


Just found a bug (hope it’s not a missreading of the system, sorry if it’s :stuck_out_tongue: )

When changing the NFS mount parameters rsize / wsize in advanced option of the web interface, the mount is not correctly done.

Exemple : I put rsize = wsize = 4096 on the web UI, save, reboot.

Launch the command :

cat /etc/mtab

and look @ the mount option, it’s : rsize=32768, wsize=32768

Hope this help !


The same happens with my installation.

I changed from Samba to NFS and after getting pops and clicks, i decidet to change rsize and wrsize values. On every values i have set, /etc/mtab keeps having the same numbers, which in my case they are: 524288, but after changing values, sound results are different, even if /etc/mtab stays the same. It’s weird :confused:


I have the same problem in that the rsize and wsize aren’t properly set. I’m wondering whether this is because I am using nfs4 and the option format is slightly different. I’ve tried to have a look at the volumio code on github to see where the mount option is set…but I haven’t been able to find it :smiley:

Anyway, I’ve fixed it by putting the rsize and wsize options in the “mount flags” box like this: