nfs mount fails after some hours

since some days I’m testing Volumio on my Raspberry 3B+, using the latest Volumio release (2.587).
My music is stored on a QNAP NAS.
So I’ve mounted the related NAS folder in My Music.
First I tried the pre-set method CIFS, which works fine so far.
However, after mounting the NAS drive, I noticed that the hard disks of my NAS did not enter the hibernate state (aka hard disk sleep mode) anymore.
Next I’ve tried NFS, which solved the disk sleep mode issue, but creates another issue:
After successful mounting, latest the next day the NAS mount is not active anymore. Sometimes this appears to happen even after some hours.
When I try to save the mount settings in Volumio, without changing anything, the application re-acts with a hang-up and Volumio cannot be reached via the browser anymore.
Only way out is to restart the Raspi.

Meanwhile I’ve checked the fstab and was wondering why I could not find any NAS related mount entries there.

I hope someone has an idea, what causes the problem with NFS mount.

Thanks in advance.


That’s an odd problem, and probably connected to your QNAP setup. I would suggest that you try the forums there to see if others are having problems of a similar nature. Please report back here when you find the solution though :wink:.

Hi there,
guess I could finally solve the problem, at least the nfs mount survives now over more than 6 days.
I would not say I found the root cause systematically but by changing some nfs settings on the QNAP side.
Basically I’m testing two Raspbery’s with Volumio installed.
For both I have entered the IP addresses in the nfs host table for shared folders on the NAS.
However, for both I’ve used the same user as UID.
After creating a second user so that both IP addresses have its own user, it seems o work.
For some evidence I changed back to one user for both and the mount was lost again the next day.

So hope that may help others, however haven’t found any similar issue described somewhere in the web.
Most likely I was the only one facing this problem.