Newbie struggling with switching to wifi

Hi all, new here, so be gentle with me.

Just installed latest version (1.55?) on an early Pi that has been sitting around in a drawer for a while. Setup has gone perfectly and I’m currently listening to audio being pushed from JRiver Media Centre. I can access the UI and everything looks normal.

I have a cheap USB audio adapter plugged in (working fine) and a Racksoy USB wifi dongle. Immediate post setup I still have the ethernet cable plugged in. I have set up access to my wifi network and the UI tells me that I’m network connected to both the wired and wireless networks. So far so good, and my complements to all of you who put this together.

But how do I now switch to using the player wirelessly? I’ve tried just unplugging the ethernet cable. I’ve powered down and rebooted without the ethernet cable. But whatever I do, I can’t seem to find the Pi either by directly addressing the local address or thru JRiver.

It’s probably just me doing something stupid, but I’m struggling. I’ve attached a monitor and the system did boot all the way through to the volumio logo. I did spot something as it was going through about no dhcp offers, but I’m not sure what I’m looking at.

Any advice gratefully received.

Please ignore the last post. I’ve been working on this for a couple of hours with no luck. I carefully type out my previous post. Press send, and then the damn thing just starts working…

Oh well. Got there in the end. :smiley:

The help is so good on this forum, just write your problem and it is solved! :mrgreen:

Sadly not as good as it seemed. Moved the Pi down from my desk to where it will live going forward, and hey presto…

Nothing. Back to where I started. Boots, but does not connect to wifi.


A bit of an update, and a plea for help again.

I now have 2 Pi connected to my network. I bought a shiny new Model 3, which is running Volumio like a dream. Very very pleased with it.

But my old Pi, as described at the top of this thread is still giving problems. I re-installed Volumio using 2.041 and whilst connected to the wired network it works fine. It even works, sort of, on the wireless network, But, it’s telling me that I’m only getting a network speed of 1 Mbps. By comparison, the other box, on the same network, approx the same distance from the router, is getting 72 Mbps.

Not surprisingly, the 1 Mbps box is very very sluggish to load anything, and as a player is effectively useless.

Any suggestions as to what I can try to debug the problem and/or to improve the wireless performance?

We’ve made a few improvements that should solve your issue… A new image will be released soon.
In the meanwhile, can you login via ssh and launch this command?

sudo /sbin/iw dev wlan0 set power_save off

Does it improve the connection ?

(this setting will be lost on reboot…)

Thanks for the tip, Steep learning curve this… er, what’s SSH (i did say Newbie :wink:)

I used Putty(?) and got through the login ok. Entered the suggested command and refreshed the UI session.

No change I’m afraid.

No hurry on this one, I’m happy to wait for the next image.

BTW, what would be the recommeded method of ussing SSH from a Windows PC?

Putty is one of the most used tools , so you’re set.

Since you do mention network issues, SSH over network might be troublesome sometimes. Remember that you could always temporarily connect the Pi to a screen and attach a keyboard. You’ll be able to use the command line as well.

Hi there.
I think I am stuggeling with a similiar problem:

Wired my connection is no problem. But I can’t get a stable wifi-connection. I do get a good connection with my PI very close to my router. But with a distance of only 3-4 meters the connection breaks down (web ui not reachable any more). All my other wifi gear works fine in the same net with much larger distances.
My system: Pi 2 Model B, HifiBerry DAC+, Wifi: EDIMAX EW-7811UN, Volumio 2.041, router: FritzBox 7272

(I already changed /etc/modprobe.d/8192cu.conf to options 8192cu rtw_power_mgnt=0 rtw_enusbss=0 rtw_ips_mode=1 with no improvement)

I tried the mentioned command:

sudo /sbin/iw dev wlan0 set power_save off

But I get a message: “command failed: No such device (-19)”. Maybe I am doing something wrong here.

I am a newbie at Linux and so I have no idea how to debug such a problem.

Thankful for any support or hint on this! Greetings.