New Version of Volumio for Rpi - Bugfixes and improvements

Ladies and gens,
thanks to your feedbacks, and the firm convintion you deserve everything to be allright, here’s my Christmas present for all of you:
a bugfix version of Volumio for Raspberry PI. The new changes are:

  • More stable system
  • Playback should stutter no more on problematic systems
  • Shairport no more resamples to 48 khrtz, but 44,1 instead
  • FFmpeg library enabled, so no-one of your music files will be left out
  • Hosts fixed
  • Now shutdown command actually shuts the pi down instead of rebooting
  • Fixed system halting after rebooting while playing
  • A minor tweak that results in sonic improvements

You are advised that in order to get the best audio quality, just go to playback, select hardware mixer and then hit save. This way the system tailors itself to your very DAC.

As usual, you’ll find this release in torrent and sourceforge link, please help by seeding it!

Let me know what is solved and what is not. Hope for you guys a merry Christmas! And of course a brilliant new year, where you’ll find what you’re looking for.

A big hug


Downloading now, thanks! Merry Christmas to all! :slight_smile:

Hi, not working for me.
The Pi boots, but i can’t acess it from web UI or ssh!
Merry Christmas


The "clicking"sound on hires audio has returned and it is worse than ever before…
Even on standard resolution audio there are hearable clicks.

Now the VLINK is not in the selectable list of Audio Output devices. So no more clicking sound, it does not work, Reverting back to the RaspyFi, that one works.

Happy Christmas!

Merry christmas everyone,

I can confirm that there are some clicks on hires files (24/88.2) .
16/44 works perfect.
I tested it with the M1 DAC and the Audioquest dragonfly.
Database update is as slow as with raspyfi - maybe because of ffmpeg ? Not a big thing… .
Further everything is fine.
Great job,

2,5 amps power supply -> pi -> M1 DAC

Can I suggest that, given that the RPi version is still a beta, you remove the protection mechanism (the reference copy hidden quietly elsewhere) so that we can make changes easily? Lock it down, by all means, when the beta is complete and you release the finished version but whilst testing this doesn’t make sense. For instance, the cifs-utils package is missing but needed if one wishes to connect to that sort of NAS. In my case, RaspyFi needed the ‘sec=ntlm’ parameter added to see the Netgear NAS, so I assume that Volumio will need it as well. Using the WebUI is difficult as the Advanced Options for the mount point keeps switching back to a simpler (or even empty) version, again I guess because of the copy mechanism,

Chris M

Merry Christmas,
I’m using a Synology Nas, B rev Pi, DIY xmos and 24/192 Dac all over WIFI. This is the first time (starting with Raspify Beta) that I can boot up the Pi and have everything connect (UI, Gnome and IOS) without having to restart MPD every time. I also find that I haven’t had the Web UI lock up Pi yet, which it did before with some regularity. Thank you, thank you, thank you! Great present. Can also confirm 16/44 doesn’t pop for me, haven’t had a chance to check hires. Seems like audio Q a little less than running flac files directly from windows laptop, but haven’t had a chance to do comparison to confirm. Again, worked nice for my setup.

Hi, first thanks for this release. I ha)ve jumped to 1.1b from RaspyFi together by upgrading from default stereo output to MUSE DAC 2704 (very cheap and 16/44 btw :slight_smile:
I have encountered 2 problems. First it seems that mpd update takes very long. For me it didn’t even finish after few hours (23 GB from CIFS).
Second is pops that appears sometimes. This is most notable if mpd update is running (I can’t understand this as ethernet uses usb bus bandwidth). The best quality I can get is from FLAC files from RAMPLAY this works well. Now I’m playing Airplay music and there are pops here and there. Could we do anything regarding this? I have tried updated to latest kernel trying to install usb fix but that branch is already merged with head. Again thanks for making this software and Merry Christmas to the Volumio Team.

Does anyone have this issue of no acess to volumio.?My hardware is raspberry v1+ Fiio E17 Dac. Well i still have a card with raspyfi.

I had the same issue with a different DAC.
Have you tried

You are advised that in order to get the best audio quality, just go to playback, select hardware mixer and then hit save. This way the system tailors itself to your very DAC.[\quote]

This one has solved the issue in my case.

Got the right IP or the Bonjour tool?
Sorry if this is to trivial for you but it was an issue that kept me from browsing volumio for a little while.

it’s working! :smiley:D yay!
Thank you!!!

Good! Happy to hear all of these feedbacks.
So, now let’s start collecting feedbacks to make everyone happy.
Just ensure:
1- if you can’t connect to WebUi, try to install bonjour or just type the Pi’s ip
2- refresh the WebUi with ctrl+f5
3-Go to system, playback select your DAC and hit save

Then ,report here if is working or not, and if there are issues. Reporting

PI: rev1 or Rev2
WORKS: what does work
BROKEN: what does not work as expected

For all of you who are using i2s DACS please report if they are working or not

thank you

Ok, my findings.
i managed to boot few times in a correct way only if i comment all lines in modules file in the fat partition. In can listen to webradios without glitches (didn’t try to add my NAS). But, if i reboot or shutdown, i can’t boot the volumio in a correct way anymore, so for use it again, i have to flash again the sd card and again comment all lines in the modules files.

Raspberry PI REV1 (ModelB) + Fiio E17 USB DAC

Hi regarding DAC problem.
Setup: Pi rev2 (model B), 8GB SD, ethernet
Linux volumio 3.10.24+ #614 PREEMPT Thu Dec 19 20:38:42 GMT 2013 armv6l

internet radio streaming today ok
flac files from ramplay
With some tweaking, it works also CIFS playback of:
Playlist position 1/1 Stereo, 24 bit, 44.1 kHz, 320 kbps

profile: Buscia
resampling: 16/44, fastest


%Cpu(s): 10.9 us, 0.7 sy, 0.0 ni, 88.0 id, 0.0 wa, 0.0 hi, 0.4 si, 0.0 st
KiB Mem: 496948 total, 450852 used, 46096 free, 72816 buffers
KiB Swap: 0 total, 0 used, 0 free, 319764 cached

22735 mpd 20 0 77688 13m 3352 S 9.6 2.7 125:03.98 mpd

pi@volumio:~$ cat /proc/asound/card0/pcm0p/sub0/hw_params
format: S16_LE
subformat: STD
channels: 2
rate: 44100 (44100/1)
period_size: 5513
buffer_size: 22050

does not work:
mpd update of cifs
i have lefted update over night and now says connected to share but remote machine is off.
I have tried play and volumio ui hangs. I needed to restart android phone (4.2) to get to the ui again. I also restarted mpd via shell to get it working.
After this i listened to web radio.
Now top says this:
top - 19:37:31 up 1 day, 5:08, 2 users, load average: 0.06, 0.03, 0.05
Tasks: 71 total, 1 running, 70 sleeping, 0 stopped, 0 zombie
%Cpu(s): 1.3 us, 1.7 sy, 0.0 ni, 97.0 id, 0.0 wa, 0.0 hi, 0.0 si, 0.0 st
KiB Mem: 496948 total, 450160 used, 46788 free, 72708 buffers
KiB Swap: 0 total, 0 used, 0 free, 319664 cached

22735 mpd 20 0 77688 13m 3272 S 0.0 2.7 124:19.17 mpd
2645 root 20 0 28904 6636 1432 S 0.0 1.3 0:03.85 minidlna
22579 www-data 20 0 31836 5400 3248 S 0.0 1.1 0:00.16 php5-fpm
19893 www-data 20 0 31836 5332 3184 S 0.0 1.1 0:00.35 php5-fpm
22766 www-data 20 0 31836 5092 2968 S 0.0 1.0 0:00.04 php5-fpm
2425 www-data 20 0 31684 4864 2728 S 0.0 1.0 0:31.30 php5-fpm
2421 www-data 20 0 31684 4384 2364 S 0.0 0.9 0:00.05 php5-fpm
2533 root 20 0 23924 4268 1852 S 0.0 0.9 0:29.22 player_wrk.php
2519 pi 20 0 6744 3868 1504 S 0.0 0.8 0:01.62 bash
2013 pi 20 0 6744 3856 1512 S 0.0 0.8 0:01.62 bash
2003 root 20 0 10920 3452 2720 S 0.0 0.7 0:00.76 sshd
2420 root 20 0 31756 3288 1332 S 0.0 0.7 0:15.19 php5-fpm
2448 root 20 0 18820 3276 2580 S 0.0 0.7 0:01.16 smbd
2430 root 20 0 39288 3144 1808 S 0.0 0.6 29:27.06 shairport

A lot of php processes, why?
Now I will try to connect usb disk to pie. Maybe I will have more luck with than with cifs.

Also, does not work:
while updating mpd sound is poping while playing from remote machine.

library sort of file by filename
browse back to last location

Great Christmass present! Works well with Musical Fidelity V-DAC and USB attached storage. It even plays .ape files out of the box! Thanks a lot!

I got some random cracks/zaps… nothing serious though :slight_smile:
Already tried different kernel settings.

Looks like the VLink is working after all. A complete reset (power disconnect) did the trick, the VLink is now showing in the list and it plays without clicks. Am now setting up the libraries, do some serious listening later and will update you all.

Hi, it works! After long time using RaspyFi, I switched to Volumio and for a few days enjoying the great sound from my digital library. Thank you to the Volumio team and keep up thegood work,