New user, new install, lots of problems!

Hi all,
just dug my Pi B out of the cupboard and decided to try this Volumio thing - it looks so simple and will stream my network music to my stereo…
Problems I have so far are:

I can never connect via a browser using volumio.local until I have first established a connection via SSH (Putty). Not very practical to do every time I turn it on to listen to some music.

The WiFI dongle refuses to work. As soon as I add it, or boot with it in (without the ethernet cable) I get nothing at all. Volumio doesn’t load up and I can’t even SSH into it.

As soon as I connect the ethernet cable - voila, all is happy again.

I’ve done LOTS of reading of all the handy forums and guides suggesing how to edit various /etc/network/interfaces files but none of my attempts have solved the useless wifi problem.

Any guidance or advice gratefully accepted.

Like every other Pi project I’ve had a go at, it hasn’t worked ‘out of the box’ and feels like more trouble than it’s actually worth, in terms of man-hours invested! Still, I guess that’s the definition of a ‘hobby’!

Awaiting with bated breath…

Thanks in advance.


Use of volumio.local is problematical in my experience. This is not a fault of Volumio, but rather the underlying standards, and how they are managed by the OS of the device you are using to connect. I deal with the problem by setting a static IP address for my device (either through your router, or by the Volumio UI)

What wifi dongle are you trying to use? Do you have an alternative one to try? What message does Volumio show on the screen when you try to add it?

It is not necessary to manually edit the network/interfaces file.

Thanks, chsims1,
having spent the last two evenings tearing my hair out I simply threw in the towel and made a fresh start on a different SD card.
Would you believe it - success straight away?!!
I shall set a static IP as per your suggestion and see how that goes.
Thanks for your support.

PS any idea how to get my Chromebook connected to Volumio?
Neither volumio.local nor the IP address seem to work on the Chromebook, nor on any of the Kindle Fire devices in the house…
Any further guidance gratefully accepted