New touch screen rotation issue


I am running 3.228 and a Touch Display plugin of 3.3.1. I recently added a touch screen to my system and set it to use a rotation of 90. The first time I started the system, it worked perfectly. The screen rotation and touch both were rotated to 90 degrees. The next time I started the system, the screen stayed at 90, but the touch went back to 0. I have tried rotating to 0 and back to 90, but the touch stays at 0. Is there a way to force the touch rotation back to 90?


Version 3.3.1 of the Touch Display plugin had a problem applying touch rotation settings. Version 3.3.5beta solves this particular problem, which could be the reason for your issue, too.

So, I recommend to

  • uninstall the Touch Display plugin.

  • Enable “Plugins Test Mode” on //volumio.local/dev .

  • In the plugin store click on the “Details” button for the Touch Display plugin and choose “Install v3.3.5(beta)”.

Enable the plugin and restart.

Hi, thanks for the quick response.

I was able to uninstall the plugin, but when I try to install 3.3.5, I get this error:

Installing fake packages for kernel, bootloader and pi lib
Download of libraspberrypi0_0.0.1_all.deb failed
Plugin failed to install!

It’s a download error. The plugin should not appear in the list of installed plugins. Is this correct? If so, try inistalling the plugn again. Download errors happen from time to time for various reasons, e.g. DNS problems.

Edit: This time it is a certificate error on I think it is being worked on, so it should be only a matter of time until the certificate is renewed.

I still can’t download anything other than 3.3.1, so I went back to that version. Now, all of the orientation seems correct, but the touch screen is blank other than the mouse pointer. Is this still a glitch with 3.3.1 or is there a way for me to get the GUI back?

So, the blank screen issue might be because chromium appears to be not installed. Probably the same issue that’s stopping me from being able to download the updated plugin.

volumio@volumio1:~$ chromium-browser -version
-bash: chromium-browser: command not found

While I was investigating chromium, I noticed that the touch orientation works randomly after a restart: sometimes it’s 0, sometimes it’s 90. After some more investigation, I found that the touch screen appears twice as an input device. I’m not sure is that’s relevant to this observation

volumio@volumio1:~$ DISPLAY=:0 xinput list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ TSTP MTouch id=6 [slave pointer (2)]
⎜ ↳ TSTP MTouch id=7 [slave pointer (2)]

I’ll keep trying to get the new plugin downloaded, but it seems like there might be something else affecting this issue.

Thanks so much for your help.

That issue should be solved with 3.3.5beta installed. And unlike 3.3.1, this version detects download errors and cancels the installation of the plugin, avoiding the impression that the plugin has been installed successfully.

This should be no problem and is not causing your issue.

Just FYI: The certificate problem has just been resolved. So you should be able to install 3.3.5beta now.

Thanks Gvolt! I was able to download 3.3.5 and that did the trick. I now have touch in the proper orientation. That being said, this version seems a little unstable. Twice while changing settings, the plugin became unresponsive. had to reinstall it to get it to work again.

What settings did you change?

I haven’t had any more issues with the plugin becoming unresponsive, but, I am seeing another issue that seems random. I run my touch screen rotated to 90 degrees. Occasionally, after a reboot, the touch screen will stay black and I’ll get a red popup saying “Error connecting to the xserver.” To recover from this, I have to uninstall/reinstall the touch screen plugin. I am now on 3.237 and Touch Display 3.3.5

Do you have any other plugins installed? If so, which?

The next time the message “Error connecting to the xserver.” occurs, please connect to Volumio via SSH, execute

cat /var/log/Xorg.0.log

and post the result.

At the moment I suspect that files the Xserver needs to start get corrupted - this might happen on a reboot e.g. due to insufficient power supply. Reason could also be a faulty SD card so you may use a fresh card for the next installation of Volumio to rule that out.

I have these plugins:
FusionDSP 0.1.32
80s80s Radio 1.0.2
Spotify 2.0.3
Volumio Spotify Connect2 3.0.8
Youtube2 0.1.8
YouTube Cast Receiver 0.1.2

Here’s the output from the log:
[ 61.549]
X.Org X Server 1.20.4
X Protocol Version 11, Revision 0
[ 61.549] Build Operating System: Linux 5.4.0-72-generic armv8l Raspbian
[ 61.549] Current Operating System: Linux volumio1 5.10.92-v7+ #1514 SMP Mon Jan 17 17:36:39 GMT 2022 armv7l
[ 61.549] Kernel command line: coherent_pool=1M 8250.nr_uarts=0 snd_bcm2835.enable_compat_alsa=0 snd_bcm2835.enable_hdmi=1 bcm2708_fb.fbwidth=1016 bcm2708_fb.fbheight=1856 bcm2708_fb.fbswap=1 vc_mem.mem_base=0x3ec00000 vc_mem.mem_size=0x40000000 splash plymouth.ignore-serial-consoles dwc_otg.fiq_enable=1 dwc_otg.fiq_fsm_enable=1 dwc_otg.fiq_fsm_mask=0xF dwc_otg.nak_holdoff=1 quiet console=ttyS0,115200 console=tty1 imgpart=/dev/mmcblk0p2 imgfile=/volumio_current.sqsh rootwait bootdelay=5 elevator=noop logo.nologo vt.global_cursor_default=0 net.ifnames=0 snd-bcm2835.enable_compat_alsa=0 snd_bcm2835.enable_hdmi=1 loglevel=0
[ 61.550] Build Date: 04 January 2022 10:05:34AM
[ 61.550] xorg-server 2:1.20.4-1+rpt4+deb10u4 (Debian -- Support)
[ 61.550] Current version of pixman: 0.36.0
[ 61.550] Before reporting problems, check
to make sure that you have the latest version.
[ 61.550] Markers: (–) probed, () from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 61.550] (==) Log file: “/var/log/Xorg.0.log”, Time: Fri Mar 11 15:53:29 2022
[ 61.564] (==) Using config directory: “/etc/X11/xorg.conf.d”
[ 61.564] (==) Using system config directory “/usr/share/X11/xorg.conf.d”
[ 61.568] (==) No Layout section. Using the first Screen section.
[ 61.568] (==) No screen section available. Using defaults.
[ 61.568] (
) |–>Screen “Default Screen Section” (0)
[ 61.568] (**) | |–>Monitor “”
[ 61.575] (==) No monitor specified for screen “Default Screen Section”.
Using a default monitor configuration.
[ 61.575] (==) Automatically adding devices
[ 61.575] (==) Automatically enabling devices
[ 61.575] (==) Automatically adding GPU devices
[ 61.582] (==) Max clients allowed: 256, resource mask: 0x1fffff
[ 61.589] (WW) The directory “/usr/share/fonts/X11/cyrillic” does not exist.
[ 61.589] Entry deleted from font path.
[ 61.597] (==) FontPath set to:
[ 61.597] (==) ModulePath set to “/usr/lib/xorg/modules”
[ 61.597] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[ 61.597] (II) Loader magic: 0x1fdf80
[ 61.597] (II) Module ABI versions:
[ 61.597] X.Org ANSI C Emulation: 0.4
[ 61.597] X.Org Video Driver: 24.0
[ 61.597] X.Org XInput driver : 24.1
[ 61.597] X.Org Server Extension : 10.0
[ 61.599] (–) using VT number 2

[ 61.599] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[ 61.600] (II) no primary bus or device found
[ 61.600] (II) LoadModule: “glx”
[ 61.603] (II) Loading /usr/lib/xorg/modules/extensions/
[ 61.732] (II) Module glx: vendor=“X.Org Foundation”
[ 61.732] compiled for 1.20.4, module version = 1.0.0
[ 61.732] ABI class: X.Org Server Extension, version 10.0
[ 61.732] (==) Matched modesetting as autoconfigured driver 0
[ 61.732] (==) Matched fbdev as autoconfigured driver 1
[ 61.732] (==) Assigned the driver to the xf86ConfigLayout
[ 61.732] (II) LoadModule: “modesetting”
[ 61.749] (II) Loading /usr/lib/xorg/modules/drivers/
[ 61.761] (II) Module modesetting: vendor=“X.Org Foundation”
[ 61.761] compiled for 1.20.4, module version = 1.20.4
[ 61.761] Module class: X.Org Video Driver
[ 61.761] ABI class: X.Org Video Driver, version 24.0
[ 61.761] (II) LoadModule: “fbdev”
[ 61.762] (II) Loading /usr/lib/xorg/modules/drivers/
[ 61.765] (II) Module fbdev: vendor=“X.Org Foundation”
[ 61.765] compiled for 1.20.3, module version = 0.5.0
[ 61.765] Module class: X.Org Video Driver
[ 61.765] ABI class: X.Org Video Driver, version 24.0
[ 61.765] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[ 61.765] (II) FBDEV: driver for framebuffer: fbdev
[ 61.765] (WW) Falling back to old probe method for modesetting
[ 61.765] (EE) open /dev/dri/card0: No such file or directory
[ 61.765] (WW) Falling back to old probe method for fbdev
[ 61.765] (II) Loading sub module “fbdevhw”
[ 61.765] (II) LoadModule: “fbdevhw”
[ 61.766] (II) Loading /usr/lib/xorg/modules/
[ 61.768] (II) Module fbdevhw: vendor=“X.Org Foundation”
[ 61.768] compiled for 1.20.4, module version = 0.0.2
[ 61.768] ABI class: X.Org Video Driver, version 24.0
[ 61.769] (EE) open /dev/fb0: No such file or directory
[ 61.769] (WW) Falling back to old probe method for modesetting
[ 61.769] (EE) open /dev/dri/card0: No such file or directory
[ 61.769] (WW) Falling back to old probe method for fbdev
[ 61.769] (II) Loading sub module “fbdevhw”
[ 61.769] (II) LoadModule: “fbdevhw”
[ 61.769] (II) Loading /usr/lib/xorg/modules/
[ 61.769] (II) Module fbdevhw: vendor=“X.Org Foundation”
[ 61.769] compiled for 1.20.4, module version = 0.0.2
[ 61.769] ABI class: X.Org Video Driver, version 24.0
[ 61.769] (EE) open /dev/fb0: No such file or directory
[ 61.769] (EE) No devices detected.
[ 61.769] (EE)
Fatal server error:
[ 61.769] (EE) no screens found(EE)
[ 61.769] (EE)
Please consult the The X.Org Foundation support
for help.
[ 61.769] (EE) Please also check the log file at “/var/log/Xorg.0.log” for additional information.
[ 61.769] (EE)
[ 61.770] (EE) Server terminated with error (1). Closing log file.

Just to confirm: Is the log from the situation where you receive the error message?

What is the brand and model name of your screen?

Yes, the screen is not working now. I will need to reinstall the plugin to get it back. The monitor is an Amazon Generic 15.6 Touchscreen. The brand appears to be USparkle. I’ll see if I can find a model number

How is the screen connected? HDMI?

Is it this one or do you have a link?

Please post the result of

cat /usr/share/X11/xorg.conf.d/99-fbturbo.conf

cat /boot/config.txt


cat /boot/userconfig.txt

Yes, HDMI.

Yes, that’s the one I have.

volumio@volumio1:~$ cat /usr/share/X11/xorg.conf.d/99-fbturbo.conf
cat: /usr/share/X11/xorg.conf.d/99-fbturbo.conf: No such file or directory

volumio@volumio1:~$ cat /boot/config.txt
initramfs volumio.initrd
include userconfig.txt

volumio@volumio1:~$ cat /boot/userconfig.txt

Add your custom config.txt options to this file, which will be preserved during updates

Touch Display rotation setting below: do not alter


Ok, and what gives

ls -al /dev/fb*

volumio@volumio1:~$ ls -al /dev/fb*
ls: cannot access ‘/dev/fb*’: No such file or directory

That meets my expectation.

Please try if this helps:


sudo curl -L -o /usr/share/X11/xorg.conf.d/99-fbturbo.conf


sudo sed 's/"fbturbo"/"fbdev"/' -i /usr/share/X11/xorg.conf.d/99-fbturbo.conf

Then reboot.