Network goes down with Volumio on Pi4

I am unable to get Volumio to run stable in my network.

Steps: I flash a fresh image to the SD Card using balenaEtcher. Plug in Ethernet, plug in Power, wait…

I did this procedure several times now and get 2 different results:

Result1: In some cases It boots correct, i can see on a monitor the login text (however i am unable to type using a Logitech wireless keyboard with dongle attached to the RPi) and I can access the wizard. After basic setup in the wizard I let it run and after a few hours. At some Point it kills my network. Meaning no other devices are able to access the internet. Using Wireshark i only see ARP messages on the network.

Result2: It kills the network a few minutes after plugin and i am unable to access the UI.

Has anyone experienced the same behavior?
I tried without the Ethernet but even after 3 hours there is not Volumio hotspot. I tried flashing a Raspberry Image to check if the hardware is OK and that worked perfectly.

Volumio Information

Volumio Version: 2.882-2021-04-24
Hardware: RPi 4 8Gb, 16Gb Sandisc Ultra, 30W power source
DAC: HifiBerry DAC2 HD
Network setup: Pi connected to an Asus router → connected to a Ubiquity Edge → Internet; Inside the network there is also a PiHole instance (not on the same RPi as Volumio)

try the 3.xx this will solve your network problem i had the same with the 2.xx
let volumio run true your router instead of pihole. and once in a while reboot pihole

Turn off Pihole, and see if you have a stable system. You can move forward from there.

@chsims1 i’m running pihole 2 as dns no problems with 3.xx

That did the trick. thanks I did not see the Beta versions of 3.xx . But am I right in assuming that the Plugins are not yet released for > version since none are shown?

plugin’s you have to install by hand because 3.xx has no plugins yet.
but most of them will work. plugins will be supported if they release the 3.xx version. it’s still beta for now.
i had the same problem and nobody had a fix… i went to 3.xx and all troubles where gone.

@chsims1 it wasn’t pihole dropping the network… volumio was.

I’m not disputing the fact that people are using Pihole alongside Volumio. I was trying to get to a stable system starting point ruling out potential problem sources.

I too use Pihole, but if I’m having network problems of any kind, it’s the first thing to be switched off while I investigate further.:wink:

i went true this rabbit hole and did all that what you ref. to but in the end it was volumio chrashing my whole,
network and not pihole that’s why i said it directly normal i would disconnect like you would.
there is some bug in 2.xx can’t put my finger on what but in 15m - 30 min the whole network went down.

I’m using pi-hole as my DNS and DHCP server and run 2 RPI 4Bs loaded with Volumio 2.xx. The ASUS, Ubiquity Edge and Pi-hole server all have the potential to be DHCP servers. Which device is your DHCP server? Are you using a fixed IP address on your Volumio RPI or is it using DHCP?

The Edge is the DHCP server. The pihole is only used for DNS service. And the RPi uses DHCP. i was not even able to get to the point where i can set a static IP.

But the solution with Volumio 3 worked. it seems the integration with RPi4 is better there. Besides having to install plugins by hand it works perfectly. Now i am more than happy to make a donation to the project.
One bug I noticed (but that is out of scope for this thread) is the setting for Hifiberry DAC2 HD HAT. I had to do that by hand in the config.

Yep, noticed similar abnormalities with my network config (Rpi → unmanaged switch → Router).

Just anecdotal as I never did detailed debugging – but my Rpi4 was having a lot of trouble on the older 4.19.y kernels. Things got better with 5.4.y, but were again fussy on the early 5.10.y kernels I was using in the initial 3.x builds. I am happy to have it stable LAN now on 5.10.50 :slight_smile:

Been having a similar issue with Volumio on a RPi Zero, as I describe here. I can connect right after a reboot, but seemingly randomly after that the Airplay destination disappears. If I force a reconnect of the RPi Zero from my router it begins working again, but only for a while.

If I put the same SD card in a RPi 3 connected with ethernet it works fine with no disconnects. I have many other wireless devices and none of them lose connectivity in this fashion.

As per this thread I upgraded to 3.078 beta, but the issue continues. Any helpful suggestions would be appreciated.

you don’t have the same issue so don’t say you do if you have a wifi problem.