Network connection problems

Hello everyone

Because I had problems with RuneAudio on my Raspberry Pi 3 not working correctly with my DAC I switched to Volumio and discovered there has been a new version released yesterday.

First I will explain what I am trying to achieve; RPi3 with Volumio, connected via ethernet, set to a static IP-address.

Before (on Volumio) I could just connect an ethernet cable to the RPi3, look up the IP-address, login the web interface, and change the address to a static one outside my DHCP scope.

Now with the new version things have changed slightly, and I can’t get it setup the way it should. First of all there is a hotspot called ‘Volumio’, where you suppose to connect to and change the settings (according to the article on this site). When I do this, ethernet does not seem to work. After setting the IP-address and reboot, ifconfig shows no assigned IP-address to eth0 and I can’t connect or even ping to Volumio.

When I connect to my wireless network via the Volumio hotspot, it works as it should. Even setting a static IP-address works fine.
If I try to change the ethernet settings after connecting to my wireless network, this time it does work. The Volumio hotspot disappears. The problem now is that ethernet and wireless are both connected to my network and this does mess up the Shairport discovery on my devices.

The only way I have found to have only ethernet connected with a static IP-address is to login to the local terminal and add the default lines for eth0 to /etc/network/interfaces. Here the problem is that the Volumio hotspot does not disappear, so everyone can connect to it and mess up the settings.

Does anyone have an idea what is going on? Or does someone have the same problem? Let me know! … 3&t=138610

See 2nd post :wink:

Thank you, that works perfectly!