Network configuration problem

Hi,
I have a raspberry 3B+ with DAC Allo BOSS, connected with ethernet cable to LAN

I flash the SD card and configure the newtwork, but as soon as I disable the wi-fi (not the hotspot! this has no influence) I loose the connection with the raspberry.
This happens either if I keep switched on DHCP or not on the cable connection.
What I would like to do is to turn off the wifi module and use only the ethernet connection.

Any suggestion?

Thank you

Try to unplug the power and let the pi start up after that. You should be able to connect with the pi if the ip is correct in the settings. I have the same problem with all of my PI’s when they loose a connection. After that they are not visable anymore. After reboot I can approach them again. Could be a bug, I normally don’t have that issue because alle of them are wired. One had a problem with a wifi extender which brought the bug on top.

Verstuurd vanaf mijn ONEPLUS A6013 met Tapatalk

Thank you, but it doesn’t work.
Beside that, I just would like a normal behaviour: if I set a static ethernet IP it should just keep it, regardless of the fact that I turn off wifi or hotspot.
Why does it change it???

Maybe try giving the raspberry a static ip in you’re router?

Verstuurd vanaf mijn ONEPLUS A6013 met Tapatalk

I ran my R Pi 3B+ for about a year on the Ethernet connection, I allowed it to get a DHCP assigned address, I had no issues.
I can’t remember if I turned off the Wi-Fi interface or not.
I’m now running the same hardware using a Wi-Fi connection, again allowing a DHCP assigned address, I’m having no issues.

Could it be your switch/router having issues with the ARP table?
Maybe power cycle the router and/or switch.

How do you enter into the pi, with the ip adres? WiFi has a different ip then lan

Verstuurd vanaf mijn ONEPLUS A6013 met Tapatalk

I had no problems with previous versions of Volumio too.
I did not think of the ARP table an/or the problem could be on the router side…

I fresh install latest version of Volumio, entering with ethernet DHCP IP.
Then regardless of the fact if I change to static Eth IP or not, if I switch off wifi I loose any connection with the RPi :frowning:

To get your DHCP server (most likely it’s your router) to allocate a static address to the R Pi:
Make a note of the MAC address of the R Pi Ethernet interface
Log into the web admin console of your router
Go to the DHCP server admin page
Set up a static allocation for the MAC address of your R Pi - EG. MAC Address 54-42-49-73-EB-DC IP Address 192.168.50.100

This way, each time the R Pi starts it will request a DHCP assigned IP address, and it will always get the same IP address.

Thank you pwstereo,
I will also try this, but the problem is not that the DHCP of the router has problems assigning a IP.

The problem is that if I turn wifi off then the Rpi is no more present in the LAN. If I perform a net scan it just disappears.

I will try to change router, as far as I can see I am the only one experiencing this issue.

So you use a wired network connection for the initial connection and setup of the R Pi.
Then when all is finished you disable to Wi-Fi interface of the R Pi.
Then you are no longer able to connect to the R Pi with the browser or app?

This seems odd, are you perhaps inadvertently using a Wi-Fi connection during the initial connection and setup?
What if you disable to wireless interface on the computer you’re using for that initial connection and setup.
Once you’re connected and working on the new install, run a ping to volumio or volumio.local, see what the IP address is, note it.
This will be the IP address assigned to the wired Ethernet interface of the R Pi.

Then if you have weird behaviour after disabling the Wi-Fi interface of the R Pi, you can try the IP address you noted instead of using the dns name.
IE. Enter the IP address into the browser address bar in place of volumio or volumio.local

Exactly. To be more precise:

  1. I install and run the fist setp uf the system connecting to what i believe is the Ethernet IP. However Volumio doesn’t know SSID and pwd of wifi, so…
  2. I change the Ethernet IP to DHCP (usually it is something like 192.168.1.177) ti manual static IP (192.168.1.7)
  3. I connect to Volumio on .7 and everything is fine
  4. I turn off Wifi and Volumio gets unreachable

The first connection is not on wifi, neither the others. Simply I don’t use hotspot or wify at all, but when I try to turn off wifi completely it changes something in the ethernet configuration too, so the device gets disconnected.
As simple as that.

Ciao
Christian