NAS working after change to mount flags

Thought this might be helpful for others struggling with NAS setup.

At first my NAS (merely a 1TB HD hanging off an ASUS router) wouldn’t mount with the stock settings loaded when adding a library. The drive would show up on the libary page, but with red x, even after 24 hours of scanning. I’m no linux expert, but I looked at previous settings that worked for me on RaspyFi 1.0. I then tried adding ‘sec=ntlm’ to the mount flags in the gui (under advanced options). Immediately after saving this change, mpd restarted and the x was replaced by a green check and library scanned NAS properly!

Now everything works perfectly thru a hifimediy dac, including 24/96 FLAC with None of the occasional clicks that happened with Raspyfi 1. I’ll be trying out newly purchased dragonfly 1.0 later today.

Nice work :smiley:

Fantastic! I had the same problem and sec=ntlm did the trick. Many thanks!

Good work!