My solution to pops and clicks

Well at least it’s playing, I don’t know if it will improve anything in my case.

I tried this today with the latest version of Volumio (Beta 1.3). Definite improvement, but not a hundred percent. I still get occasional small pops on playing 96k FLACs, and small pops with an occasional big pop playing 192k FLACs. But as I say, a lot better than it was before the firmware update. This is with the M2Tech Hiface 2 DAC.

For comparison I played the same tracks back with my current preferred solution, the Wolfson Audio Card (for the Pi), which uses the !2S interface. That played the tracks back perfectly, with no pops whatsover.

So whether the new firmware update solves the USB problem completely may depend on your specific DAC. For me it still seems that the I2S interface is the way to go.

I always unbind the usb dac from usbhid module for optimal results. Did you test it with this tweak?

No I didn’t. I was following your post where you say to apply the rpi-update (having installed binutils). I thought I saw a previous post from you where you said the usbhid tweak was no longer necessary? Maybe I imagined that! I’m not sure how to apply that though, is there a post that covers that? It would be interesting to get the M2Tech DAC playing hi-res tracks back perfectly, and then I could do a comparison between that and the Wolfson, purely on the sound they produce. It is just an issue with hi-res stuff. Standard CD-quality tracks play back pretty much perfectly with the M2Tech in Volumio, and always have, including in Raspyfi.

Check this post!
https://community.volumio.org/t/my-solution-to-pops-and-clicks/784/9

Note that it has to be given in every boot.

Sent from my GT-N7100 using Tapatalk

OK, thanks. I’ll give that a try, if I can figure out the values for my setup.

I noticed a little further down your post where you say the usbhid fix is no longer needed;

"We have a new beta fimware – raspberrypi.org/forums/viewt … 26#p532626

Testing it right now - it works fine. No need to apply the usbhid unbinding fix."

So, obvious question, why are you still applying it?

I had a go, but without any success. Trying to give the command you quoted, like

echo -n “1-1.3:1.0” > /sys/bus/usb/drivers/usbhid/unbind

just results in the error ‘echo: write error: No such device’

In addition I don’t seem to have the line with the numbers in dmesg that you mention.

Hi,
New in this game but followed your advice here as I had some pop&click issues

After firmware updat the sound output was horrible, absolutley horrible. So I went for the Volumio UI update script.
Now I cannot contact the Pi through the webbrowser and Pi is not even showing up as a renderer device in my phone.

I can however Putty it and log on

I am on 3.12.18+ it says when I log in. Date for update UI was today i.e. 19 may -14

Any advice much appreciated

Update the firmware again without adding BRANCH=next. Latest firmware is in main bunch at the moment.

Sent from my GT-N7100 using Tapatalk

OK did that.
I am now on 3.12.19+ but no change i’m afraid.
Cannot reach it through the WebUI and it will not advertise itself as an AirPlay renderer.
Putty works though!

Any more ideas?

I get this now and again.
I find if I stop mpd then I can access the web interface but as soon as I restart mpd the web interface stops again.
Only solution I’ve found so far is to re-install. I tend to keep a backup on my laptop so I don’t loose my WiFi settings or library

The new firmware is not 100% a solution to everyone. From my experience it has helped me set up 3 different dacs sucessfully. Maybe your dac is not one of the ones that take advantage of it.

OK I will try to reinstall.

Is there a way to select which firmware to install? I might try to work my way up through the releases till I hit a “sweet spot” or again end up in a “dead end”

However the unbinding and other stuff discussed here might still be of value, or?

As far as i remember, there is a way to choose a specific snapshot of firmware to install. I have never used it and I am not sure if the choose between different snapshots is from local backups or not. Visit this thread as I believe that some users refer to procedures like the one you are looking for:

raspberrypi.org/forums/viewt … &start=225

With regards to usb unbinding, in my case this was the magic step that changed everything. Only a test will give you the answer for your own setup! Of course unbinding the usb from usbhid does not need you to have the latest available firmware. You can do this at any time.

Back in business! But …

Tried the 1.2 beta -> Pops&Clicks
Tried Unbind -> Pops&Clicks

Tried the 1.3 Beta -> Pops&Clicks, but fewer and worse
Tried Unbind -> Pops&Clicks, but fewer and worse

Im now on 3.10.36+

Tried activating I2S Generic (I have a Musical Fidelity V-DAC) + Reboot + unbind
No improvement

Realised I had been playing with the different Kernels, switched back to Default, and so far this sounds good :slight_smile:
Will have to give it a thorough test this evening. But it is promising.

Does any of the above make sense?

Hi again,
Reverted the I2S as that should not add anything for my USB DAC
And it still behaves good providing I Unbind

So basically what I have found out is (for my Pi at least)

  1. Use Volumio 1.3beta
  2. Do unbind for the USB
  3. Kernel choice can have a major impact

I will cycle through the kernels tomorrrow again just because …
Oh and I have disabled the volume control, but I do not know if that matters, will have to check that to.

Thanks for your help Tux

Hi all, this fix is included in V1.4 ?
I really have problems playing USB DAC and Pi over Ethernet connected to NAS

pops and clicks

Hi Karim,

you can try this : http://volumio.org/forum/audio-dropouts-t1478.html#p5764
Let me know if it helps.