Music scan crashes network

I´ve tried Volumio in the past but decided then to go for Runeaudio. Now Volumio2 is out and I wanted to check it out.
So I installed version 2.041 on a RPi3 with the Spotify and display plugins. The I mounted my NAS with NFS and started my music scan.
Scanning is very slow and I noticed a considerable drop in network performance.
Normaly, when I do a network speed test with iperf3, I get close 1 Gbits/sec. But with Volumio2 scanning, network performance drops to 14 Mbits/sec. It´s not that Volumio uses 980 Mb/s because the pi only has a 100 Mb/s lan port.
I checked volumio with journalctl -f but there is nothing special, only that it scans slow.

I tried this also with a RPi2 and different cables all with the same result.

Is there anyone with the same problem or anyone who has a clue?


Try to add

decoder {
    plugin      "ffmpeg"
    enabled     "no"

then do

systemctl restart mpd

then wait 5 seconds and hit rescan in my music

Let me know please

Michelangelo thanks for the quick response.

Added the code to /etc/mpd.conf however no change. Scan and network still slow.

Scan does also not store music found. After each reboot ¨my music¨ is empty.

Michelangelo, I am noticing a number of similar posts about library scanning. You said on Github earlier that this was a mpd/fmmpeg problem. Using your code to disable ffmeg for mpd, results in a big soft crash on Odroid C2. This is noted elsewhere on the forums, but gkkpch reports that he has used it successfully in the past. I’m a bit confused about inconsistencies here.

I would be interested to understand why this seems to be a problem on Odroid C2 and Cubox (assuming here that it is the same problem) but it doesn’t show itself on RPi … just showing my ignorance obviously :wink:

My assumption here is that debian package is somehow broken (or conflicts with the particular version of mpd that we compiled).
At this point I guess the best solution is skipping to mpd 20.2 …

There is a new version of mpd 0.20.3. from january 25. I tried to compile it however I get a lot of errors.


make[1]: *** [src/output/libmpd_a-Internal.o] Error 1
make[1]: Leaving directory ‘/tmp/mpd’
Makefile:4669: recipe for target ‘all’ failed
make: *** [all] Error 2