Music Library not following symlinks when scanning folders


When using the Music Library page to scan folders from an NFS share it does not appear to follow symlinks. Other music shows up as long as it or its folder is not under a symlink. If I mount the NFS share on another machine (e.g my laptop) I can see and traverse the symlinks as expected.

Why can’t Volumio find files under symlinks?


I don’t think it is Volumio, so much as a problem with Linux and NFS. I guess your test machines are Windows based, and Windows doesn’t strictly follow the NFS specifications. Now, this may well be different in later NFS versions, you will have to do a Google search for more information. I do know that it is not possible to even create a symlink from my Synology NAS GUI; I would have to do it from the command line.

It’s not a problem with Linux and NFS. I use NFS shares with symlinks all the time on my local network and they work just fine. The NFS share in question is exported from a Linux machine and it works as expected from both MacOS and Linux clients.

And in fact it also works as expected from the console on the Volumio device – tested just now via SSH and I can follow the symlinks on the mounted share – so there’s clearly something wrong with Volumio itself not being able to do the same.

Interesting reply, so thinking perhaps it was an NFS version problem, I symlinked (from cli) an entire folder on my NAS to another folder, and tried it it in Volumio … it worked fine (which was a nice surprise). Volumio is using v3.

So, back to your problem

Can you explain exactly how you followed the symlinks? Perhaps also a system reboot, and a log might give an indication of what is happening.

what about that : mpd.conf(5): Music Player Daemon config file - Linux man page

Required Parameters


Control if MPD will follow symbolic links pointing outside the music dir. You must recreate the database after changing this option. The default is “yes”.


Control if MPD will follow symbolic links pointing inside the music dir, potentially adding duplicates to the database. You must recreate the database after changing this option. The default is “yes”.


This specifies where the db file will be stored.

But this is activated by defaut…

Ok, I took another look at what is going on. I think the problem is that the NFS share is being mounted one directory level lower than what I need.

I have this directory structure on the NFS export:


where Music-Raw is where I keep the files I’ve purchased / downloaded (might have multiple versions, it’s backed up externally, etc.) and Music is the “view” folder I want Volumio to import from. I have symlinks from Music pointing to Music-Raw.

The export is being mounted at …/media/Music but it actually needs to be mounted at just …/media for this to work as I want.

So I guess my actual question is: how do I get Volumio to mount X but only look for music in X/Y?

Is there any way to do that in the Volumio UX or do I need to manually mount and have Volumio import from the “local” FS?


FWIW, this is the problem. I can manually mount the NFS share at the parent directory, then symlink the Music subdirectory into /mnt/NAS and Volumio is able to scan everything as I expect.

It’s unfortunate that the network share is no longer managed by Volumio with this solution, but I guess it works.

I’ve also tried using hardlinks on the source system as an alternative approach. That works too and preserves the NFS share management in the Volumio UI.

:+1: Well done for sorting. I know symlinks are convenient within a filesystem, but I try to avoid otherwise.