Multiroom rp3


I have install 12 rpi3 with the latest volumio image, all equiped with external USB audio card and a smb server. All 12 rpi receiving a webradio stream generated via a rpi3 with darkcast and icecast2 .However the rpi3’s don’t show up in the web page in the Multiroom section?
Could that be the result of multi ethernet switches that are connecties between the rpi3?
Also , when setting up the ip/mas in the networkpage, the always set to be in the dhcpcd.conf file.


Did you try before enabling darkcast and icecast2? I don’t know anything about them, but the RPis in my network all appear in multiroom when using snapcast. I wouldn’t have thought that the switches would make any difference, but I am willing to be corrected.


I tested it with 2RPi volumio on a small local network, and then the are displayed as multi room. No wi tried the same with 12 rpi and used a ip range 172.20.20+x.58, x stand for room number, with mask and the aren’t displayed as multiroom.

How many RPI do you have in your network?


I only tried 3 so not much more than your basic test. I wonder if there is a number limit. You might like to make an enquiry on Github I did notice whilst searching for an answer to your question, that an app (Sound@home) for the original Volumio (1 not 2) was limited to 5 devices … no idea if that was just the app or a Volumio decision.